Kadafi-Audio
Audible Advocate
  • 0
  • 11
  • 0
Registered since

Sep 16, 2018

Battery not lasting long and ANC still poor

I had the first gen qc35ii which since updating from factory firmware the ANC became terrible/worthless.

I was asked to return that pair of headphones which i did then received a new pair, slightly updated version with completely different factory firmware to my first pair. I was asked to update them to latest firmware which i did, still no improved ANC.... However the worst thing with these new pair is the **bleep** battery doesnt last longer than 2 days.. my listening habits have not changed, my original pair would last me almost a week with my listening habits. Do these have a dud battery? Also ANC is still poor in fact feels worse. I was told if i update the firmware and it is still not good to get back in touch....

5 REPLIES 5
cesarv
Friendly Fanatic
  • 15
  • 58
  • 2
Registered since

Jun 6, 2018

Re: Battery not lasting long and ANC still poor

Return them, really. And if you get a new pair, do NOT upgrade the firmware.

Moderator

Re: Battery not lasting long and ANC still poor

Hello,

 

Thank you for messaging the community today. I am so sorry to hear that you are experiencing some issues with the ANC and Battery of your QC35 headphones. We would love to do what we can in order to get this resolved for you.

 

You have stated that you got an updated version of the headphone, are you referring to a QC35 to QC35 II upgrade of your original headset? I would like to confirm this so that I can provide you with the most accurate information. You can confirm which product you own through the Bose Connect App, if you connect your product and visit your product settings and information, this will inform you of the model of headphones you own. 

 

Please let us know, we would love to do what we can to assist you with this matter. 

 

Kindest regards,

Tegan M - Community Support 

Kadafi-Audio
Audible Advocate
  • 0
  • 11
  • 0
Registered since

Sep 16, 2018

Re: Battery not lasting long and ANC still poor

Hi Tegan,

 

My first pair was qc35ii... the none AR version.... Those were returned to Bose because ANC went poor and I got white noise with ANC after a firmware update. On the factory firmware the original pair were fine.

When Bose sent me the replacement which I have now, they were also QC35ii but AR enabled versions. But the firmware on them was not the same firmware as the original none AR enabled pair that I had originally and the ANC is terrible on these new ones also.

I posted about it on these forums after my experience of the new pair being same to worse (some admin has since deleted that post) and I was told to then update the firmware on the new pair and test... . I did... it still isn't how I remember it on my first pair...

So anyway, today whilst I had them paired to my phone, sound stopped working even though they were connected to my phone... I swtiched them off and then on again and got a loud buzzing noise coming out of them.... I turned the switch to the off position and the noise still persisted and LED indicators to show power were still ON even thhough the switch was off..... So i plugged in a usb cable to power and unplugged it and they sorted themselves out...

These new pair are definitely faulty in some way with poor to none existent ANC, poor battery life, also sometimes they wont play sound even though they are paired to whatever device whether it's the PC or Phone even though bluetooth is on and linked, sometimes i get a brief cutout of audio with both PC and phone and now the new issue with the buzzing noise coming out of the speakers.

My experience with the QC35ii is getting from bad to worse!

Kadafi-Audio
Audible Advocate
  • 0
  • 11
  • 0
Registered since

Sep 16, 2018

Re: Battery not lasting long and ANC still poor

The new AR enabled ones don't have the very first original firmware 😞 so any replacement i get will still have newer crap firmware!

Kadafi-Audio
Audible Advocate
  • 0
  • 11
  • 0
Registered since

Sep 16, 2018

Re: Battery not lasting long and ANC still poor

Can anyone direct me to support on this??? Does Bose support on these forums no longer exist?