Highlighted
Moderator

Re: Beeeep sound and weird screech sound

Sorry to hear this @SuperHofstad. Have you tried the update and reset process mentioned in this thread? The steps are below for ease of trying:

 

  1. Go to btu.bose.com on a computer and update your headphones software.
  2. Perform a product reset, to do this, turn off the headset and wait 30 seconds and then plug the headset into a wall outlet using a USB charger, then wait 5 seconds. After that unplug the USB cord from the headset and wait 1 minute once you have completed this turn the headset back on.

I look forward to hearing from you!

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Highlighted
Participant
  • 0
  • 1
  • 0
Registered since

Aug 9, 2020

Re: Beeeep sound and weird screech sound

I tried the product reset (30s off, 5s plugged in, 60s off). This occurs in either the left ear or right ear reproducible. When it connects to the computer youtube plays fine. I have minecraft loaded and it also works fine until I do something specific in game. As soon as that happens one of the ears pops and the high frequency screech starts until I turn off the headphones. This has occurred before, but never in such a controlled/reproducible way.

Highlighted
Moderator

Re: Beeeep sound and weird screech sound

Sorry to hear this @whitney, can I please ask if you have tried updating the headphones at all? Also, just to confirm, this only happens when you are gaming?

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Highlighted
Participant
  • 0
  • 1
  • 0
Registered since

Apr 21, 2020

Re: Beeeep sound and weird screech sound

FIXED!
TL;DR; Disable microphone

 

I could hear the faint sound of my keyboard with the beep and screech, then I noticed the microphone icon was on at the bottom-right corner of the windows. Hovering over the icon I found out my game (Starcraft 2) was using the microphone by default even when I don't use the voice chat. (For this particular game though, "Disabling the Voice chat" isn't enough to fix. Refer to this video https://www.youtube.com/watch?v=SKlqMJyA4z0 for fix.) I hope other folks can find a similar solution to their problems.

By the way, the video above briefly mentions one solution that could work for other applications, which interestingly doesn't work for Starcraft 2.

 

If this helped you in any way, please 'Like' to help others find this solution!

All my new content is uploaded to http://www.youtube.com/JaKaTaKtv (No new videos are uploaded to this channel) To stay up to date on my latest work like, fo...