Alex Toft
Silent Starter
  • 0
  • 1
  • 0
Registered since

Nov 13, 2019

Bose 700 Firmware Update Simply Doesn't Work

Hello. I had my 700's delivered on release day and overall they've been amazing, but they have a habit of randomly powering down after ~5 mins of music which is very annoying.

 

I tried to update the firmware on my Mac (brand new, all up to date), and the app does not even launch.

 

I do not have a Windows machine, but tried using VMware Fusion on my Mac with a Win10 VM. This tries to start the update but immediately fails.

 

This is incredibly disappointing from a user experience perspective. I'm a very technical chap with 30 years experience in tech, I write drivers and kernel code etc, so hardly a novice.

 

Really? What on earth?

1 REPLY 1
Moderator

Re: Bose 700 Firmware Update Simply Doesn't Work

Hello Alex, 

 

Thanks for reaching out and welcome to the Bose Community Forums. 

 

I am sorry that you are having some trouble with your new headphones, but I would love to work with you to resolve them. To start with, please can I confirm a few things: 

  • Where did you purchase the headphones? 
  • Can you connect your headphones to the Bose Music app? If so, have you been prompted to update within the app? 
  • Have you tried a different browser to try and install the firmware? 

I look forward to your reply. 

 

Kind Regards, 

Vicky W - Community Support