LexS10
Participant
  • 0
  • 2
  • 0
Registered since

Jan 16, 2021

Bose NC 700 empty device list

The device list in the Bose Music app is empty. It was working fine up until a few hours ago.

 

I have a Samsung Galaxy S10 running the latest Android and HP Elitebook 850G5.

 

I cannot add or switch any devices. It only remembers the devices I used previously. I can add the headphones back using the phone settings menu but the functionality is limited.

 

I tried everything including, unpair and repair, unistall the app, clear cache and check permissions but no luck.

 

I have seen several threads with the same problem but no solution has ever been given by Bose since May 2020!

 

This is a very serious issue that renders the device useless. Please post a solution as soon as possible or I will be forced to return the device and ask for a refund.

 

Screenshot_20210117-023141_Bose Music.jpg

I also noticed the headphones have wierd interference with 5GHz WIFI causing devices to drop connections and stutter when I use them. For now I solved it by using only the 2.4GHz SSID my modem has built in but this is not permanent.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Jeff_G
Moderator

Re: Bose NC 700 empty device list

Author Accepted Answer selected by LexS10

Hello LexS10, 

 

Thanks for posting. 

 

I'm sorry to hear you're having issues with your headphones. 

 

Have you tried clearing the device list on the headphones by holding the power/Bluetooth button for around 10 seconds? 

 

Have you also tried setting up via a different smartphone? 

 

I'll look forward to hearing more from you about this.

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!

View solution in original post

2 REPLIES 2
Jeff_G
Moderator

Re: Bose NC 700 empty device list

Author Accepted Answer selected by LexS10

Hello LexS10, 

 

Thanks for posting. 

 

I'm sorry to hear you're having issues with your headphones. 

 

Have you tried clearing the device list on the headphones by holding the power/Bluetooth button for around 10 seconds? 

 

Have you also tried setting up via a different smartphone? 

 

I'll look forward to hearing more from you about this.

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!

View solution in original post

LexS10
Participant
  • 0
  • 2
  • 0
Registered since

Jan 16, 2021

Re: Bose NC 700 empty device list

Hi,

Thanks for the info!

After a few attempts, clearing the device list using the power button worked.

For the record, installing the app and pairing on a different smartphone didn't work.

Best regards