Highlighted
Wistful Whisperer
  • 0
  • 3
  • 0
Registered since

Apr 11, 2018

Bose QC35 II keeps forgetting USB Bluetooth device on Windows!

I have a QC35 II with the latest firmware (4.5.2) and a computer with a Onvian Bluetooth 4.0 adapter. I notice that every time I turn on the headset, I will need to go through the pairing process again on my Windows desktop to connect to the computer. In Settings on Windows, it has QC35 II as one of the paired devices. The windows device name will show up in the Bose Connect app right after pairing. But it does not show up after I power cycle the headset. It seems that the headset cannot remember the Windows device.

 

As I check further, the headset can correctly remember my iPhone and my MacBook, but has difficulties remembering the Windows device. I tried to clear the Bluetooth device list in the headset and re-setup the device list. The problem is still there.

 

So far I have had three QC35 devices. For my QC35 I had before, I recall that it could remember all the Bluetooth devices include Windows desktop. And with my first QC35 II, reconnecting to Windows devices are not reliable. About 90% of the time the reconnecting won't work. I asked for a repair and Bose sent me another QC35 II with a later manufacture date (06/19). However, with this newer headset, reconnecting to Windows device never works.

 

This sound like a firmware issue to me. Can Bose fix this issue in the coming firmware update?

4 REPLIES 4
Highlighted
Moderator

Re: Bose QC35 II keeps forgetting USB Bluetooth device on Windows!

Hello Gavin,

 

Thanks for reaching out via the Bose Community. 

 

I'm sorry to hear you are having issues with your QC35 II when using it with Windows. 

 

When powering the headphones off and switching them back on, are you going straight back to the Windows computer? Or are you using it with another device? If you have connected to another device, the headphones will be seeking that device when turned back on. Before it connects to anything, you can slide the power switch over to Bluetooth momentarily for it to seek the next device it remembers. 

 

Have you also tried using another Windows computer that features internal Bluetooth audio streaming support to confirm this isn't an issue with the adapter? 

 

If anyone else is having similar issues please feel free to join in the discussion. 

 

Kind regards, 

 

Jeff G - Community Support

 

 

 

Feel more. Do more. Be more.
New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started.
Highlighted
Wistful Whisperer
  • 0
  • 3
  • 0
Registered since

Apr 11, 2018

Re: Bose QC35 II keeps forgetting USB Bluetooth device on Windows!

Hi, Jeff,

 

Thanks for your reply.

 

Through the whole connect and reconnect bug repro, I was sitting in front of my desk and the desktop with the Bluetooth adapter was always by my side. I do have my phone (iPhone) as one of the connected devices and the headset always connects to the phone. QC35 I/II claims to support connecting to two devices at the same time. With my QC35 I, it would connect to my phone and my computer in sequence. But with my second QC35 II, it never connect to my computer after connecting to my phone.

 

I remember in rare case, when my first QC35 II connected to both devices successfully, it said connected to [my computer name] and [my phone name]". Is it possible that the headset will try to connect my phone after connecting my computer but will stop trying if it connects to my phone first?

 

I don't have another Windows computer that has internal Bluetooth. With the headset being remembered in Windows and the Windows device disappearing from the device list in Bose app, it really sounds like a bug in the headset to me. Assuming that I had another Windows device with built-in Bluetooth and the problem did not repro on it, would it be considered as a compatibility issue of the headset? Why does the headset only forget the Bluetooth adapter but can remember my phone and my MacBook?

 

I do want to get the bottom of this issue as this is very inconvenient to me. Please let me know if there is any diagnostic data I can get from the headset to help investigation.

 

UPDATE:


This morning when I came to my office, I found that the QC35II could connect to both devices and the prompt says "Connected to [comptuer name] and [phone name]". I tried to turn off and turn back on the headset and the problem did not repro. I was happy as I thought the problem was magically gone. Then after a while, I noticed that my phone somehow was not in connected state with the headset. I went to the Bluetooth setting page on my phone and connected to the headset. Then the problem reappeared. After a power reset, I was not able to re-connect to my desktop again.

 

After that, I tried turning off the Bluetooth on my phone. But the headset still only tried to connect to my phone without trying to connect to my desktop.

 

So a summary of what I've found:

1. There is time when the headset can connect to both devices at the same time, which means QC35 can sometimes store the connection information of the Bluetooth adapter.

2. If the headset connects to the desktop first (based on the prompt), it will be able to connect to my phone.

3. If the headset ever connects to the phone explicitly (not during turning on) after it remembers the Bluetooth adapter, it somehow forgets the Bluetooth adapter.

4. When the headset is able to remember two devices, it is undetermined which one will be connected first. But the actual order may affect how many devices it can connect.

 

This still sounds like a bug to me that happens intermittently.

Highlighted
Silent Starter
  • 1
  • 1
  • 0
Registered since

Feb 4, 2020

Re: Bose QC35 II keeps forgetting USB Bluetooth device on Windows!

I've been having the same problem (for quite some time now).

 

I haven't figured out an exact repro, but my setup is QC35II connected to my iPhone and a work PC (via USB bluetooth adapter).  I also had them connected to a laptop at one point, but that has been removed.

 

Sometimes I turn off the headphones and plug them in before going home, sometimes I just plug them in (I think they turn off automatically), but this difference doesn't seem to make any meaningful difference when trying to reliably reproduce the issue.

 

Most often, I simply lock my computer when I go home.  Sometimes when I come in the next day, the headphones will pair back up with both phone and computer.  Sometimes they will only pair with the phone.  I don't recall ever having an issue with them not pairing with the phone, but it can be multiple times in a week where they fail to connect to the computer.

 

When I look in bluetooth settings on the PC, they show the headphones as "paired", but when I click "connect" on the PC, it fails to connect to the headphones.  This is when the headphones are on, but happens regardless of whether they are in "pairing" mode or not.

 

When this occurs and I look in the Bose Connect app on my phone, I do not see the PC on the list.  What's really interesting is, during the time when I also would occasionally use them with my laptop, but the laptop wasn't present, I would see my phone as connected, and the laptop as not connected, but would not see the PC in the list.  This specifically is what makes me think it's a problem with the headphones (and not the bluetooth dongle).

 

The only way I've found to get them reconnected is to go into Windows, "Remove Device" for the QC35II's, then re-pair them.

 

I would love a solution to this.

Highlighted
Quiet Contributor
  • 0
  • 1
  • 0
Registered since

Feb 5, 2020

Re: Bose QC35 II keeps forgetting USB Bluetooth device on Windows!

Hi there my name is Daniel,

I have pretty similar issues with my QC35 II headphones. I'm currently using two TP-Link Bluetooth adapters. One at work and one at home. But apparently I have to pair the headphones everyday again.  Twice actually, considering that I use them on both computers daily.

So I checked out the Bose App this morning and QC35 II had still my home PC stored in its device list (I deleted it recently because I thought this could help). But as soon as I re-paired the headphones with my computer at work, the previous entry from home was replaced by the one from work.

After the firmware update I did yesterday I hoped that the problem was gone, but it's still the same behavior. (f.y.i. before yesterday i never did a firmware update)

 

On the other hand I know that using the same type of BT-Adapter shouldn't be a problem. 1st they have individual MAC-Adresses and 2nd my logitech mouse doesn't care. ^^ It always connects direcly to the computers and I just had to pair them once. And the QC35 is supposed to connect to 8 devices (mouse only 2). 😉

 

Can anyone help?