jeremiabryan
Quiet Contributor
  • 0
  • 1
  • 0
Registered since

Jul 14, 2019

NC 700 Red/White blinking LED

I left my headphones charging and when I went to get them they wouldn't turn on, and are now blinking red and white

4 REPLIES 4
Highlighted
rcpost
Audible Advocate
  • 3
  • 7
  • 0
Registered since

Jul 2, 2019

Re: NC 700 Red/White blinking LED

I had this happen a few nights ago when the battery died rather abruptly. I grabbed the cable that I had just used to charge my phone - Android, using the same type "C" connector - and plugged it into my new NCH700s. It immediately started blinking red/white. Thought it might be caused by a non-Bose cable, so grabbed the cable supplied with my headset, plugged it into the same charger and the headphones. It began to blink the same red/white for a few ticks then started blinking white (indicating it was charging). Left it charging 'till next morning and observed the LED was solid white (indicating fully charged). However, when powering up, the voice told me that battery was very low. So, plugged it back in and it blinked white going solid after about 30 minutes. Powered up, voice says I now have 20+ hours. It seems to be behaving normally, however I haven't tried to charge since then.

While I can't find anything that says the user must use the Bose supplied charging cable, you may want to try that if you haven't already.

Moderator

Re: NC 700 Red/White blinking LED

Hello jeremiabryan, 

 

Thank you for your post and welcome to the Bose Community. 

 

I'm sorry to hear that you are having problems with your new Noise Cancelling Headphones 700. 

 

@rcpost Thank you also for your post. I'm glad to hear that your headphones have resumed functionality. Of course, if you do get any more problems, get back to us and we'll be happy to help. 

 

@jeremiabryan Could you please confirm that you are using the official charging cable provided with the headphones?

 

I look forward to hearing back from you. 

 

Warm regards,

Charlotte G - Community Support

ysj
Silent Starter
  • 0
  • 1
  • 0
Registered since

Sep 5, 2019

Re: NC 700 Red/White blinking LED

I have the same problem of red/white LED blinking alternatively. I charged it with the official cable provided from Bose. I charged it with my computer for 2days before I had this symptom. What should I do?

Moderator

Re: NC 700 Red/White blinking LED

Hello @ysj,

 

Thank you for contacting the community. 

 

This LED signal would indicate that there is an error with your headset. I am very sorry that you are experiencing this issue. Please contact your regions Bose product support team for further assistance regarding this.  Please follow this link, select your region and scroll down to "Contact Us". There you will find the appropriate contact information and an agent will happily assist you. 

 

Let us know if you have any further questions. 

 

Kind regards,

Tegan M