Highlighted
Silent Starter
  • 1
  • 2
  • 0
Registered since

Jan 7, 2020

NC700 connected to MacBookPro activates the microphone and has poor audio quality.

Almost every single time I connect my NC700 to my MacBookPro using Bluetooth, they start in "Communication mode", activating the microphone and having really really poor audio quality.

I know WHY it does this, and I know how to turn it back into normal mode, but I don't know how to PREVENT this from happening. I'm bored by having to do this every time.

 

To anyone else wondering; if you have Skype/Discord/iOS-Simulator or any other microphone-capable application running on your Mac when you connect your headphones, they go into "communication mode" immediately because the Mac thinks you need it for the relevant application you have running. To turn it into what you want, simply Option+Click (ALT+click) the speaker-symbol in the Mac status bar and select "MacBookPro Microphone" as Input. After a second, it will turn normal and everything is perfect.

 

But you have to do it every single time you connect the headphones if you have such applications running. And I always have that, because that's my job. And it annoys me.