Highlighted
Audible Advocate
  • 2
  • 4
  • 0
Registered since

May 12, 2020

Performed a reset on the Bose 700 after recent firmware update and can no longer connect to Bose App

I saw the post from Bose in the recent firmware update forum to try resetting the headphones, removing the BT connections, and re-add the devices which sounds like "start fresh" situation.  Sounds good.

 

  • I first held down the power button for 10 seconds but never heard the prompt that any BT's devices were reset.
  • I then held the power button down and plugged in the USB-C, held the button down longer but the BT light never started blinking again per the instructions.
  • I did a 'forget' on the device in iOS, I disconnected the BT device from my Surface.
  • I then tried to re-add the device back into the iOS app.  It wouldn't let me delete the existing device, and it wouldn't reconnect either.
  • Deleted the iOS Bose app entirely.
  • Tried another reset on the headphones by doing the same procedure described above.
  • Did a hard reset on my iPhone X.
  • Re-installed the Bose iOS App, logged in.
  • Went to add new device, it detects the Bose 700, but when I try to pair I get an error, "Ooops something went wrong".  

I'm not able to clear this problem, and the device seems forever screwed up.

 

I can re-add the headphones to my Surface Pro and iPhone, but the Bose app will not pair it.  This is beyond stupid.  Only recourse appears to be return to Amazon.  😞

 

iOS 13.4.1

Bose Firmware: 1.4.12