dmgerst
Participant
  • 0
  • 1
  • 0
Registered since

Apr 16, 2021

Prevent auto-switch

Bose product name: QC35 II

 

Country USA

 

What devices were you using that were affected and what version are they on Samsung S9+ / PC

Detailed description of the issue and steps to reproduce.  I got my QC35 II for dual purpose at the office. I have it connected to my PC for phone calls and video conferencing. I also have it connected to my smart phone for listening to music when not on a call.  If I'm listening to music on my phone, the PC is always interrupting the music and switching back to the PC for any sound. I would like the headphones to not automatically switch.  I get tired of manually switching back to the phone that I usually give up and just listen to the Pc. The sound quality on my work Pc sounds like a tin can compared to my phone.... is there a way I can stop the PC from automatically taking control?  

 

What environment do you experience the issue in? Office

 

When did you start to experience the issue? Did it work correctly previously?  Always

 

Any troubleshooting steps you took.  just disconnect from PC, or listen to music on PC and not phone

 

 

2 REPLIES 2
Jessie_O
Moderator

Re: Prevent auto-switch

Hey dmgerst, 

 

Thank you for your post and welcome to the community! 

 

In regards to your post, there is no way to disable the auto-switch if you are intending to use the headset in this way. I would recommend tweaking your notifications settings so you do not hear them in the headset. 

 

Let me know if you have any further questions! 

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
joelirwin
Expert
  • 388
  • 1835
  • 68
Registered since

Jun 15, 2018

Re: Prevent auto-switch

@dmgerst(I do not work for Bose)

First of all, you made a comment on 'sound quality' like tin.  That is part of the standard for bluetooth.  The QC35 which is BT compliant depends on two basic mutually exclusive profiles - stereo streaming or A2DS and Voice Over IP / Phone or HFP (hands free protocol).  Only one ca be active at a time.  The 'sound' associated with a phone call has been for decades and decades, 'mono' and low quality 'sampled'.  The music you hear in HFP mode will sound the same as the music you hear on your phone when you are put on hold.

As far as the dual functionality.  This is a 'by design' feature of all Bose BT products - both headphones and speakers.  And there is no way on any of the Bose devices to limit the number of simultaneous connections except by turning off the communication from one end or the other:

 

1. From the bose end, to stop the PC from interrupting but keep connection to the phone, you need to 'un-pair' the PC.  This is a 'pain' imho having to keep pairing and un-pairing to hear the PC

2. From the PC end - some PCs like my Dell laptop, have a switch to disable BT temporarily.  Unfortunately, often it also disables wifi.   Or you can through a software interface, temporarily disable BT.

There is one other very unconventional 'solution'.  Do a wired approach.  Connect a wire to your QC35 and connect it to a stereo splitter - then connect one part of the Y to the PC and the other to the phone (iPhones need a lightning connector to go wired).

All of the above are 'workarounds'.  Again, Bose does not consider the functionality of dual connections as a bug and so I don't personally believe you will see any 'enhancement' to disable the dual part/functionality (but who knows? 🙂 )

And let's not forget the final 'solution' assuming you keep your QC35 in the solution - two BT devices - use the QC35 for the phone and some other BT device for the PC.  The second device doesn't have to be a Bose device.