Andrew Herman
  • 0
  • 1
  • 0
Registered since

Jun 9, 2021

Problems connecting QC 30 to iphone 12

Before creating a new topic, please search the Community to avoid creating duplicate threads. If you are posting about a problem, the more of the below details you can include (if applicable) the easier it will be for others to try and help. Go to for a helpful post on how to find relevant information, including your firmware and app version information!


Bose product name

QC 30




Firmware Version


App Version


Bose Connect 16.0


What devices were you using that were affected and what version are they on (e.g. Samsung Galaxy S9 on Android 11, iPhone X on iOS14, etc.)i

iPhone 12 


Detailed description of the issue and steps to reproduce


I just bought a new iPhone12 but cannot connect my QC 30 earphones by bluetooth.  I have tried to do so via the Bose Connect app but it cannot locate the earphones even when they are right next to the device and when the proper lights are activated on them.  I have turned off and charged the earbuds several times as per advice given on the forum concerning similar problems with earlier iphones.


What environment do you experience the issue in? (e.g. noisy office, quiet kitchen, etc.)


When did you start to experience the issue? Did it work correctly previously?


I have not been able to connect to the new iPhone at all


Any troubleshooting steps you took


1) Turning QC30 off for 5 minutes and then turning it back it on


2) Turning iPhone off and on 


3) turning bluetooth off and on




Re: Problems connecting QC 30 to iphone 12

Hello Andrew Herman, 


Thanks for posting and welcome to the Bose Community Forums. 


I am sorry to hear you headphones are having difficulties connecting to your new iPhone. Let's get this fixed. The troubleshooting you have tried so far is great. The steps below should help too:


1. Rebbot your headphones. To do this:
- Turn off the headset and wait 30 seconds
- Plug the headset into a wall outlet using a USB charger, then wait 5 seconds
- Unplug the USB cord from the headset and wait 1 minute and then turn on the headset.
Clearing the headset memory of previously paired Bluetooth devices. To do this power off your headset and press and hold the Power/Bluetooth button for 10 seconds until you hear "Bluetooth device list cleared" from the headset.
2. Go to and try and update the firmware of the headphones. 


Let me know how you get on!

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!