jk000079
Participant
  • 0
  • 3
  • 0
Registered since

Jan 19, 2021

QC 35 II unable to autoconnect to Android when configured as "Use for Calls" only

Bose product name

QuietComfort 35 II

 

Country

Germany

 

Firmware Version

latest as of 19-Jan-2021: 4.8.1

 

App Version

Uninstalled the app, since I see no benefit from it. The behavior described here happens irrespectively if the app is installed, or not.

 

What devices were you using that were affected and what version are they on

Samsung Galaxy S20+, SM-G985F/DS, Android 11, Kernel 4.19.87-20699066 (7-Jan-2021), but previous versions had the same problem.

 

 

 

-----

Detailed description of the issue and steps to reproduce

The bluetooth headset's primary usecase is for confcalls.

I need it to work 100% reliably in that usecase.

 

If I leave the default configuration, after pairing with the phone, then they connect for both Calls and Audio. That results in me losing the audio from on ongoing confcall whenever some app on my phone decides to make a notification sound, since the headset automaticaly switches audio to that app, and never returns to the ongoing confcall. The way this works in Android, is, that even if the Headset is no longer connected to the confcall (calls app), the calls app does not output via the speakers on the phone either. The end result is, that because of a 1 second ping from some other app, I randomly lose connection to my ongoing important confcall - often without even realizing, that it happened, since I simply do not hear anything, and don't know, if nobody is just saying anything, or I got disconnected, or my headset decided to switch to a different app as audio source.

 

!! The absurdity of that happening on a 200+ Eur premium headset is mind boggling !!

 

As a workaround, I have unpaired the headset from my laptop, left it paired only with my phone, and I have therefore switched off the "Use for Audio" toggle for the QC 35 II on my phone, leaving it only as "Use for Calls". This works fine to get undisturbed confcalls, *but* at the cost of the Headset no longer connecting to the phone automatically, after I turn on the Headset.

 

More specifically: After turning on the QC 35 II headset, it says "Battery 100%. Connected to Samsung Galaxy S20." and 0.5 second later: "Samsung Galaxy S20 disconnected". And I have to manually navigate to the bluetooth menu, find the QC 35 II, and click it, so that it actually connects, and I can use it for the upcoming confcall.

 

I refuse to accept this clumsy solution with a premium headset, and strongly hope, that it is just a user error, that can be fixed .. and therefore I am open for suggestions.

-----

 

 

 

What environment do you experience the issue in?

Irrelevant to the problem.

 

When did you start to experience the issue? Did it work correctly previously?

No, this is how it seems to be designed to "work".

 

Any troubleshooting steps you took

Yes, already described above, in the Problem description.

I did as well update the firmware to the latest version, un-paired and re-paired the headset with the phone, and as well uninstalled the Bose app - just in case it was causing some interference with the Android bluetooth driver .. Nothing helped.

4 REPLIES 4
Jessie_O
Moderator

Re: QC 35 II unable to autoconnect to Android when configured as "Use for Calls" only

Hey JK000079, 

 

Thank you for reaching out to us and welcome! 

 

I'm sorry to hear of the issue you are experiencing and will do all we can to assist you! 

 

I know you have mentioned that you have cleared the Bluetooth pairing on the headphones, I would also recommend deleting the pairing on your source devices as well before you reconnect them. 

 

Let me know if this helps!

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
jk000079
Participant
  • 0
  • 3
  • 0
Registered since

Jan 19, 2021

Re: QC 35 II unable to autoconnect to Android when configured as "Use for Calls" only

Hi Jessie,

 

Thanks for the feedback - that did not help either.

 

Steps done (this can be reproduced at will within 5 minutes by anyone who has this headset):

 

1.- unpaired the headset from the smartphone (the only device it was still paired with)

 

2.- executed for a bluetooth reset and "Bluetooth device list cleared." as detailed in:
https://www.manualslib.com/manual/1819926/Bose-Qc35-2-Series.html

 

3.- Turned on the Headset

 

4.- a PopUp from the Bose app on the smartphone asked me if I wanted to connect to the headset - allowed the connect, which seems to have automatically paired the headet as a bluetooth device
(Android -> Settings -> Connections -> Bluetooth -> 1 device connected -> under paired devices: Connected for calls and audio, 100% battery remaining)

 

5.- Clicked the setting wheel next to the QC 35 II paired bluetooth device and turned off the toggle "Use for Audio"

 

6.- Back to Paired devices -> now it says: Connected for calls, 100% battery remaining

 

7.- Turned off the headset

 

8.- Waited 10 seconds

 

9.- Turned on the headset

 

10.- Headset announces itself: "Battery 100%, Connected to Galaxy S20, Galaxy S20 disconnected"
<-> which is exactly the behavior, I was complaining about, when the driver believes, that I have manually disconnected the headset, if I have left it configured as "Use for calls" and not as well "Use for Audio".

 

It is clearly the way how the headset firmware is written to behave - ignore, that a headset can be asked to be connected as "Use for calls" only, and therefore, when it has been manually disabled for "Use for Audio", it just automatically disconnects again, immediately after the initial connect.

 

In the meantime I have found a bluetooth device connect widget on the android store, which at least allows me to single-click force connection of the headset again, without having to navigate several levels down in the Android settings menu,

   never the less, this "Connect automatically + Disconnect automatically + Connect manually again" procedure takes anything between 5 and 10 seconds, before my headset is actually ready for a confcall, after I turn it on, and is annoying, when I get called ad-hoc, and thus did not have time to "do the magic dance" to be ready to have a confcall using this headset.

 

Thanks,

 Josef

Keith_L
Moderator

Re: QC 35 II unable to autoconnect to Android when configured as "Use for Calls" only

Thanks for the detailed breakdown of what's been happening with your headphones! 

 

I've been testing this myself with my own QC35 IIs to see if I can re-create the issue as well and I am getting exactly the same behavior when "use for audio" is toggled off. I'm raising this up to our development team to investigate further too.

 

If you have any further information you think would be useful let me know! I'll let you know if the team ask us for any further info as well!

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
jk000079
Participant
  • 0
  • 3
  • 0
Registered since

Jan 19, 2021

Re: QC 35 II unable to autoconnect to Android when configured as "Use for Calls" only

Just in case anyone else will stumble across this thread - in the meantime I've (coincidentally, really) found a workaround to be able to have the headset connect automatically, to an Android smartphone, as "connect for calls" only.

 

The key is to *not* unpair the headset on your Android smartphone, after you set it up there as connected "for calls" only (e.g. using my list of steps provided above), but perform the "Bluetooth device list cleared." step again on the headset, and then allow it to connect back to the smartphone.

 

That way the smartphone still remembers, that it should connect this headset "for calls" only, and the headset does not "get the memo", that you disconnected it's use "for audio", and therefore it does *not* automatically disconnect again, immediately after the automatic connect, after turning the headset on.

 

This seems to persists over multiple times of turning of the headset on/off, and thus, at least to me, is a valid workaround for this usecase.