Highlighted
Participant
  • 0
  • 3
  • 0
Registered since

Nov 14, 2018

QC35 II Flash red whilst charging

Hi, 

 

I have the QC35 II and after a short time charging they start flashing red,  if I unplug them and try again it’s ok. Didn’t know if anyone has seen this before, I don’t want it to be damaging the battery or something! They are only 6 months old.

Many thanks.

Nathan 

3 REPLIES 3
Highlighted
Community Manager

Re: QC35 II Flash red whilst charging

@Nathan2503

 

Thanks for your message. Happy to help out today. As noted in our guide HERE, a flashing red LED typically indicates that the headset needs to be charged. Is the headset's power switch securely set to the "off" position while charging? 

 

What are you using to charge the headphones? They require a power input of 5 V DC, 1 A - have you tried using an alternative compatible power adapter with the headset? What adapter are you currently using with the headset? More info on charging can be found here.

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Highlighted
Participant
  • 0
  • 3
  • 0
Registered since

Nov 14, 2018

Re: QC35 II Flash red whilst charging

@Andy_B 
The power adapter is the only thing I could think of, so I have changed it to an Apple one. Maybe that will work. Just wondered if anyone had seen it before.

 

Nathan

Highlighted
Community Manager

Re: QC35 II Flash red whilst charging

@Nathan2503 Understandable - do let u know how a replacement adapter goes. I too had a quick look through our forums, but couldn't see many similar comments. 

 

Have you also tried swapping out the micro-USB cable? If the issue persists, I have two final suggestions. Firstly, ensure the firmware is up to date, to see if this is a software error. This can be done by connecting the headset to a computer and then visiting our website HERE. Secondly, perform a reset on the headphones via the guide HERE.

 

If this fails, there may likely be a hardware fault. As the headphones are still only 6 months old, they will still be covered under Bose warranty if purchased from an authorized Bose retailer. In this case, contact us directly, and we'll be happy to help you get this resolved. Click HERE, select your country, and use the "Contact us" section at the bottom of the page. 🙂

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!