macmel
Quiet Contributor
  • 0
  • 2
  • 0
Registered since

Aug 9, 2019

QC35 II - Select a FW when updating

New to the forum, was given a QC35 II which is on FW 2.0.1. Quite old FW but the headset is in New condition as it wasn't used much.

Now my question is can I select the FW when updating as I have been reading about the issues the latest FW 4.5.2 that has been reported. If possible to select, which FW is the best. I understand that a downgrade is almost impossible thatst reason I want to update to a good FW. TIA

1 REPLY 1
Highlighted
joelirwin
Wistful Whiz
  • 230
  • 978
  • 25
Registered since

Jun 15, 2018

Re: QC35 II - Select a FW when updating

@macmel 

Version 2.0.1 is the ORIGINAL / first firmware that came with the QC35ii in Sept. 2017.  There have been six firmware releases since the original, the latest being 4.5.2.  Bose is very specific about what you can do - you can use its web app or Bose Connect app to upgrade to 4.5.2.  That is your only official option.  There are those here who go to reddit to use a different version 3.1.8 but Bose does not support that process - whether it be an upgrade (in your case) or a downgrade from 4.1.3, 4.3.6, or 4.5.2.

I would personally recommend you don't do anything at all.  I can not as a QC35ii owner myself think of anything in particular for a QC35ii that was made back in 2017 that you would need to upgrade for.  And unfortunately, Bose does not provide any detail information in the release notes associated with each firmware upgrade so aside from the upgrade for "AR" which your model does not support, there is nothing obvious you would need to upgrade for.