RobDustan
Participant
  • 0
  • 2
  • 0
Registered since

May 4, 2020

QC35 lost connection and battery status voice

My QC35s have stopped working. The in-ear voice is no longer working. A green power light is visible. Bluetooth light is off. When switched on I can hear the noise cancelling switch on. They show as connected to a device that they have been paired with.  Forgetting the device I can not re-pair again.

 

Looks like Bluetooth isn't functioning but that is my guess.

 

Tried the reset (power cable in, disconnect wait and turn on). No idea what else to try.

Can you assist,

Rob

3 REPLIES 3
Hector_B
Moderator

Re: QC35 lost connection and battery status voice

Hello RobDustan, 

 

Welcome to the community! This is a very strange issue and not something I have heard of before. 

 

I appreciate that you have attempted to perform a reset and would highly recommend we look into updating the headset. To do this please connect your headphones to a PC/Mac via the USB charging cable, once connected please visit our online updater and follow the on-screen instructions. 

 

We look forward to hearing back from you with the result of this update. 

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
RobDustan
Participant
  • 0
  • 2
  • 0
Registered since

May 4, 2020

Re: QC35 lost connection and battery status voice

Thank you for, the reply. I have updated the firmware nd still the problem persists. It would appear that the bleuetooth has stopped working (almost). It is recognised on an (new connection) Android phone with NFC(?) but not on Bluetooth.

 

I let the charge run out completely and recharged to full (constant green light) but this has not fixed the problem.  I am beginning to believe these are dead but I would welcome any thoughts.

 

Rob

Tegan_M
Moderator

Re: QC35 lost connection and battery status voice

I am sorry to hear this persists.

 

Do you get any audio if you do an AUX connection by any chance?

 

Can you try to clear the Bluetooth list? Slide the bluetooth for 10 seconds until you hear 'Bluetooth device list cleared'

 

Does this provide any improvements?

 

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started. And don't forget to check out our new and improved Community Ranks and Rewards!