Highlighted
Participant
  • 0
  • 2
  • 0
Registered since

Mar 30, 2020

high noise cancellation not working after update

After updating the latest firmware, the high noise cancellation no longer works!  In fact both the high and low noise cancellations now sound more like static. How can this be fixed? Or how can I at least revert to the previous firmware version?

2 REPLIES 2
Highlighted
Expert
  • 340
  • 1513
  • 46
Registered since

Jun 15, 2018

Re: high noise cancellation not working after update

1. Go to the post on firmware 3.5.2 which is pinned to the first page.  This is an ongoing issue that we as users have been discussing for well over a year.  Bose is still actively looking at it but we have not had an update (another pinned post) since the end of Jan.  With Covid, I suspect this issue may drag into 2021.

2. Bose does not support or recommend a firmware downgrade and doing so may or may not solve your issue.  People here have reported mixed results not to mention, it is not obvious which one to go to.  Also keep in mind that Bose moderators (I am a non-Bose user like you), will delete text from a post if it discusses how to downgrade.  You'll need to Google on your own.   From the Bose perspective once you upgrade you can't go back.  And to 'complicate' things - not everyone upgrading to 3.5.2 has the issue - I don't for example.  Another option you have if you are within warranty is exchange (which as you would guess could be problematic in the current covid environment - most stores are closed and Bose can only be contacted via FB and Twitter).  Another option would be to sell yours on ebay and rebuy someone elses and hope you get an earlier firmware.  (Apple stores used to have Qc35ii's with older firmware but they are closed).

Highlighted
Participant
  • 0
  • 2
  • 0
Registered since

Mar 30, 2020

Re: high noise cancellation not working after update

Thanks!  I appreciate the background info and follow-up!