Highlighted
odog1094
Silent Starter
  • 0
  • 1
  • 0
Registered since

Jul 19, 2019

Bose A20 Feedback

I've owned the Bose A20 for about a month and today on my takeoff roll I experienced a crazy amount of feedback in the headset. It was like the engine noise was being amplified and not reduced. The feedback then become sporatic throughout the flight. Anybody else experience this issue? I'm wondering if it's the headset or my avionics. Thanks

3 REPLIES 3
Moderator

Re: Bose A20 Feedback

Hello odog1094, 

 


Welcome to the Bose Community, thanks for taking the time to post. 

 

I'm very sorry to hear you are having issues with your A20 headset. Can you please confirm which version of the product it is that you have? (version 1, version 2, with/without Bluetooth, CPC, LEMO, GA, U174.) 

 

Note: Do not post your serial number.

 

Can you please confirm: 

 

- Have any modifications been made to the headset or the aircraft? 

- Does the issue only occur at a certain altitude? 

- Is there any damage to the down cable? Have you tried detaching it and re-attaching it to ensure a secure connection?

- Is there any damage to the boom mic?

- Have you tried re-inserting the headset cable to the aircraft panel?

- Have you tried replacing the AA batteries? 

- Can you please check to ensure the cushions are intact and securely affixed?

 

I will look forward to hearing from you. If anyone else is having similar issues or has come across this problem in the past and found a solution, please feel free to join in the conversation!   


Kind regards,

Jeff G - Community Support

 

Xyz987
Noisy Narrator
  • 222
  • 1683
  • 50
Registered since

Oct 18, 2017

Re: Bose A20 Feedback

I'm guessing you need new batteries.  I've used a Bose A20 headset for several years and I love them.  Never had an issue.  Flew 3 hours today with them.

warrenpolly
Silent Starter
  • 0
  • 1
  • 0
Registered since

Oct 20, 2019

Re: Bose A20 Feedback

Hi Jeff, 

 

I had the same issue yesterday - on my first use of the a brand new GA A20 (BT) headset - out of the box with new batteries. Looking at your questions below...

 

- Have any modifications been made to the headset or the aircraft?  - No, and other headsets worked fine in that aircraft

- Does the issue only occur at a certain altitude?  - Straight after startup. Feedback was so bad I had to use another headset for this flight.

- Is there any damage to the down cable? Have you tried detaching it and re-attaching it to ensure a secure connection? - no it's brand new and seems in tact

- Is there any damage to the boom mic? no

- Have you tried re-inserting the headset cable to the aircraft panel? yes

- Have you tried replacing the AA batteries? They were brand new

- Can you please check to ensure the cushions are intact and securely affixed? Yes, they are

 

I had not made any bluetooth connection either prior to or at the time. One of the instructors at my flying school said he found you should turn on the noise cancelling first, before powering up the aircraft avionics but I am yet to try this. Am interested if you have any further information or if anyone else there has the same?

 

Thanks,

Warren