Highlighted
Participant
  • 0
  • 5
  • 0
Registered since

Jun 20, 2020

Don´t work

I have the Bose Frames, bought in USA, now I am in Argentina. They worked properly about a year. One day they stopped working. They charge, and sometimes they start, says battery 100% percent, connected to... and they stop. 

I updated the software and I can connect them to my PC but can't make them work.

 

Please help.


Thank you

10 REPLIES 10
Highlighted
Moderator

Re: Don´t work

Hey @Zeta3,

 

I hope you've enjoyed your Frames so far! To confirm, there isn't an issue with the Frames charging, but with them connecting to your phone?

 

Or, are they connecting to your devices, but not playing audio?

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Highlighted
Participant
  • 0
  • 5
  • 0
Registered since

Jun 20, 2020

Re: Don´t work

Thank you Sam,


I really enjoyed them, I became an absolute fan. It is so confortable to have nothing in your ears and still have your music or your phone calls. 

Of course it has no noise cancelling and in loud places it could be hard to listen but this is not really a problem, Additionally I would like to have clear cristals in order to be able to use them indoors.

 

Overall the best earphones i ever had.

 

Now back to the issue, there is no problem with the connection, they appear to shut down suddenly. And many times you can´t even turn them on.

 

Highlighted
Moderator

Re: Don´t work

That's great to hear, @Zeta3. Hopefully, this issue can be resolved swiftly.

 

When the Frames turn off suddenly, is this due to low battery? For example, do you ever hear the product warn of a low battery before shutting down? What usually causes them to turn back on? What is the process you'll usually follow to bring power back?

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Highlighted
Participant
  • 0
  • 5
  • 0
Registered since

Jun 20, 2020

Re: Don´t work

No, they are fully charged but they turn off in a second after turning on. In order to turn them back on I have to put them back to charge, sometimes it happens, sometimes it doesn't. Most of the time they don't respond at all.

Highlighted
Moderator

Re: Don´t work

Thanks for confirming. The next steps would be to explore your service options for the Frames. You can do this by visiting this link here, and talking with your local team. They will be more than happy to help!

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Highlighted
Participant
  • 0
  • 3
  • 0
Registered since

Jun 27, 2020

Re: Don´t work

I have the same problem.  But i have only owned them 2 months.  They are great (when work).  After charging they say “battery 100%” But when i put them on my my face they suddenly stopped working and act as if if there is no battery charge.  Ie they dont connect, no voice, nothing. Dead. 

For the last week it looked as if the battery was weaker. They lasted maybe an hour of play, but i lived with it as they were so good.  But then this morning they just didn't work at all. 

I read this article and tried putting them back on a charger and now there is no light at all when charging ( ie looks like the battery might be totally dead) 

 

please tell me its something simple you can help with as i invested in polarized and prescription lenses, and have now travelled to UK so it will be a complete pain to replace.  And very expensive investment to lose.

Highlighted
Participant
  • 0
  • 3
  • 0
Registered since

Jun 27, 2020

Re: Don´t work

update:  when i turn them the right way up and push the button, the light flickers for an instant.  

Highlighted
Moderator

Re: Don´t work

Hi RikkiTahta,

 

Thanks for reaching out, I am very sorry to hear that you are having this experience with your Bose Frames.

 

If you have tried all the troubleshooting within this thread, please reach out to your local technical support team for further assistance. You can reach out to your local support team via clicking this link and selecting your region, this ... Please scroll to the bottom of the website and there you will find a 'Contact Us' tab, this will provide you with all the relevant contact information for your country.

 

Thank you.

Feel more. Do more. Be more.
New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started. And don't forget to check out our new and improved Community Ranks and Rewards!
Participant
  • 0
  • 5
  • 0
Registered since

Jun 20, 2020

Re: Don´t work

I can´t reach the number, is it working? For Argentina it says 001-800-222-1889, try from my phone and Skype, same result, nobody answer