yaroldb
Quiet Contributor
  • 1
  • 5
  • 0
Registered since

Jun 24, 2019

Second pair stopped working

I've had my Alto Frames for about 3 months now.  2 weeks of that time was spent waiting on my replacement pair to arrive.  My first pair worked great.  No complaints and I loved these things.  One day I was walking outside and I heard a crackle noise.  I look back and saw nothing, didn't think anything of it and then I heard it again.  I was not listening to music or on the phone so I am not even sure if they were on.  I went to turn them on and nothing.  Got home, tried to charge them, nothing.  They were completely dead. Would not charge, would not work at all.  Called up support, they tried a few things but it was not responding.  They sent me an RMA and I sent back the defective frames.  2 weeks later (give or take) I get a brand new pair.  Not refurb, brand new still in the plastic.  A newer version of the ones I had as the plastic felt stronger and the case was not only magnetic, it also had a little button on it.  It's now been about 2 more weeks and this pair has stopped working.  This time, they charge, show up as connected via usb on my computer when I charge it, but the button does not work.  I have been able to get it to turn on if unplug it from the charger and press the button for about 20-30 seconds but this does not work everytime.  When they do work, the button does not function at all.  I disconnected it from my iPhone, connected it to my iPad and same problem.  I was able to get them working long enough to get the firmware updated but that did not change the function problems I am having.  Never got them wet, don't leave them in the car so I can not explain why this is the second pair that have stopped working.  I will be calling in to Bose soon to try again.  I am very disappointed as I really like these things and want them to work. Any advise to avoid another 2 weeks of waiting for a replacement?

 

Thanks 

 

 

4 REPLIES 4
Moderator

Re: Second pair stopped working

Hi Yaroldb, 

 

Thanks for posting and sharing this information with us. This is a very strange issue that I haven't yet seen, however I would love to assist you further with this. 

 

Firstly, I would recommend that you attempt to manually update the Frames via the Btu.bose.com updater as well as only pressing the button for a short amount of time rather than holding it. 

 

Can you please confirm which device you are connecting the Frames to and which software version your device is running?

 

I look forward to hearing back from you. 

 

Kind Regards, 

Hector B - Community Support 

 

 

yaroldb
Quiet Contributor
  • 1
  • 5
  • 0
Registered since

Jun 24, 2019

Re: Second pair stopped working

Hi Hector, 

 

I spoke with support and they sent me an RMA to return the frames.  The rep said he would expidite it but ony on the return order, so here goes another 2 weeks of so without them.  Sorry, it's frustrating that all and all I'll spend a month without my frames because they keep breaking. Awesome customer service however.  This is my last shot at this.  If the next pair also break, I am done with these. 


Thank you, 

joaoush@yahoo.com
Silent Starter
  • 0
  • 1
  • 0
Registered since

Nov 6, 2019

Re: Second pair stopped working

Hi guys. I purchased my new frames at a FNAC in Paris last month, and I was very happy and proud of it in every possible way, but then the charging issues showed up, I upgraded the firmware as suggested, and it got a little bit better but now it is not charging or turning on. It does not blink or make any noise at all, just like the issue reported abouve. I do live in Brazil and I need some help on how can I have a local support or a replacement of my frames.

Moderator

Re: Second pair stopped working

Hello joaoush,

 

Thank you for your post and welcome to the Bose Community. 

 

It's great to hear how you enjoyed using the Bose Frames but I am sorry that you are presented with some charging issues. 

 

I would have to recommend that you reach out to your local support in Brazil using the contact details here Bose Support Brazil.

 

Please let me know if you have any further questions.

 

Warm regards,

Charlotte G