Highlighted
Participant
  • 0
  • 1
  • 0
Registered since

Oct 25, 2020

QC35 II Gaming edition - Sound only in right ear when mic is connected

Hi,

 

I received a few days ago the "nice" QC35 II Gaming edition. Every now and then, when the mic is plugged into the USB receiver and the headphones, the left ear of the headphones won't have any sound. I tried the reset thing, sometimes it works, sometimes it doesn't. I have a recent Alienware PC, Win 10. When I switch back to Bluetooth, I have sound in both ears.

 

Any tips? Am I the only one having this issue? 

 

Thanks

1 REPLY 1
Highlighted
Moderator

Re: QC35 II Gaming edition - Sound only in right ear when mic is connected

Hey Banatage, 

 

Thank you for posting and welcome to the Bose Community! Sorry to read that you are experiencing audio issues with your left headphone. 

 

Can you please let us know if this issue happens with all devices you attempt a wired connection with or just this Alienware PC? I'm sorry to read that the reset didn't resolve this issue for you, another step we want to attempt is to manually update the headset. 

 

To do this please connect the headset to a PC/Mac via the USB charging cable. Once connected please visit our online updater and follow the on-screen instructions.

 

We look forward to hearing back from you.  

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!