cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
kly
Contributor
  • 0
  • 3
  • 0
Registered since

Apr 17, 2018

ANC is terrible after upgrade to 1.5.1

Whatever Bose is telling, I'm not letting this go without some extra effort:

https://community.bose.com/t5/Wireless-Headphones/Bose-QC-35-II-firmware-2-5-1-ANC-is-terrible/m-p/1...

Can't believe they keep closing threads without offering a solution.

 

However, I might have an extra piece of information:

I tried to upgrade with the Bose Connect app first which failed.

It said it had lost its connection and tried to reconnect.

It did something though because the reduced ANC was immediately noticeable.

I tried upgrading 2 or times with the Bose Connect app (on an iPhone X) which always failed.

 

After that I tried to upgrade with the dektop app on a macbook.

This time the upgrade succeeded but the ANC is still a lot worse than it was.

 

Notice I own the first version of the QC35.

Purchased it end of august last year.

3 REPLIES 3
cddcc
Participant
  • 0
  • 1
  • 0
Registered since

Jun 16, 2018

Re: ANC is terrible after upgrade to 1.5.1

I have the same problem

Just upgrade my QC35 from 1.3.2

How to downgrade

 

help

Pilou42
Advocate
  • 34
  • 145
  • 4
Registered since

Jul 19, 2017

Re: ANC is terrible after upgrade to 1.5.1

There were no changes between 1.3 and 1.5 regarding ANC. Try reseting your headset and doing an update from a PC.

To be sure your brain is not tricking you, use a vacuum cleaner, put your QC35 on and off to see if you can hear a difference.

BalakrishnaThati
Participant
  • 0
  • 1
  • 0
Registered since

Jun 26, 2018

Re: ANC is terrible after upgrade to 1.5.1

I am also facing same issue, I bought today this headphone from a private seller when I pair and play it was awesome sound/NC, but as soon as update version to 1.5.1 I didn't feel NC, I clearly hear my colleagues talk.

Bose, what is the point to buy expensive headphone?

Why can't we downgrade firmware 1.0.6? I feel simply wasted money