Highlighted
hamalon74
Silent Starter
  • 0
  • 1
  • 0
Registered since

Feb 11, 2019

Bose QC30 earbuds - Low popping sound and reboots. Then real loud popping sound and goes off.

Hello.   I have a pair of QC30 earbuds.   Lately I have been wearing them and all of a sudding I hear a slight pop sound and the earbuds reboot.   Then comes back on connecting.   Then the pop again and reboots.   Then I hear a really loud pop and it goes off completely.   Is there anything we can do for this?   This is not the left ear popping sound...This is happening in both ears.   

 

 

1 REPLY 1
Moderator

Re: Bose QC30 earbuds - Low popping sound and reboots. Then real loud popping sound and goes off.

Hi hamalon74,

 

Thanks for posting. I am sorry to hear about that. I know that you may hear a slight pop when you turn the headsets on. This occurs as the noise reduction circuitry powers up. But, if its happening and then the headset is rebooting it might be an issue with the ANC microphones. I would try a few things:

  • Make sure the microphones on the earbuds are clean of debris. 
  • Check and make sure that your headphones software is updated by going to btu.bose.com on your computer and following the instructions.
  • Reboot the headphones.

To reboot the headset

  • Turn the headset off and wait for 30 seconds.
  • Plug the headset into a USB power supply via USB cord and wait 5 seconds. (Power supply needs to be plugged into the wall with power on).
  • Unplug the USB cord from the headset and wait 1 minute.
  • Turn on the headset and test if the headset works properly.

 

If you try those steps and are still having that issue, I would recommend contacting your local support team for assistance. Here is a link you can use. Click on your region, scroll down until you see "Contact Us."

 

Regards,

 

Tony G - Community Support