Highlighted
discorules
Silent Starter
  • 0
  • 1
  • 0
Registered since

Jan 2, 2019

Bose QC30 red light

Hello,

 

So i have the same problem other users here had : i forgot to turn off my QC30 and the other day it won't turn on anymore. When i try to charge, all i get is the red light. And when i try to update, it starts but lose connection after a while.

 

My product has more than 1 year, so the warranty won't cover.

 

It's clear this is a software issue. Is there any solution ? 

 

Thanks

3 REPLIES 3
Moderator

Re: Bose QC30 red light

Hey Discorules,

 

Thanks for reaching out to the community and sorry for the trouble you're having! There are a few suggestions we recommend that can help you. 

 

Can you please try visiting btu.bose.com to update the headphones? 

 

 

How long do you have them charging for? Is it a solid red light? 

 

 

Also, can you please try a different USB charger and cable if that is possible? 

 

 

Let us know when you get the chance.

 

 

Thank you again,

 

 

Mohsin - Community Support

 

 

 

Ben1217
Silent Starter
  • 0
  • 1
  • 0
Registered since

Apr 10, 2019

Re: Bose QC30 red light

I have tried to download it loses connection, the light flashes yellow like it is charging for like 5 seconds then turns into a solid red light. I have charged over night and it does not charge. It has done the for the last three days, I have taken them to bestbuy and they used their charger and it didn’t work.
Community Manager

Re: Bose QC30 red light

Hi Ben1217,

 

I'm sorry to hear that troubleshooting did not resolve the issues you're experiencing with your QuietControl 30 headphones. Have you tried updating the firmware on a different computer, or alternatively using a different USB port on the computer?

 

I also recommend performing a product reset on your headphones. This can be done by:

  1. Turn off the headset and wait 30 seconds
  2. Plug the headset into a wall outlet using a USB charger, then wait 5 seconds
  3. Unplug the USB cord from the headset and wait 1 minute
  4. Turn on the headset

 

Should the issue persist I encourage you to reach out to support in your region via our website HERE. Select your location and use the "Contact Us" feature.

 

Kindest,

Andy B