cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
adina.laptuca
Contributor
  • 0
  • 3
  • 1
Registered since

Apr 12, 2018

Bose QC35 II not working at all after firmware upgrade to 2.5.1

Hello.

 

I have a pair of Bose QC35 II and i just updated them to the latest firmware version available 2.5.1.

 

After upgrading them, they stopped working properly. No google assistant anymore, buttons do nothing, and i am not able to find my headphones on any device - so i can't connect them to anything (bluetooth not working - also bose connect app does not find them).

They turn on, the battery led is working, noice cancelation is active but the bluetooth led is dead.

 

I tried to reset the headphones with those steps, plug/unplug wait, and also did a firmware downgrade to 2.1.3 using the "A V D arrow up, arrow down" combination. I don't know what else to do, just before the update they worked perfect.

 

Any ideas?

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
adina.laptuca
Contributor
  • 0
  • 3
  • 1
Registered since

Apr 12, 2018

Re: Bose QC35 II not working at all after firmware upgrade to 2.5.1

Author Accepted Answer selected by adina.laptuca

So..in the first place i upgraded to 2.5.1 then downgrading to 2.1.3 then again upgrading to 2.5.1 in the despair of fixing it somehow. All this time i used a different cable, not the one from bose box. Now, when getting home and doing more research online trying to find a solution, i found a guy saying that you should use the data cable from headphone's box. So that's what i did, downgrading again to 2.1.3 but this time using the cable from the box and this fixed my problem => now everything is working perfectly again.

 

I am never upgrading again or using a different cable.

 

 

View solution in original post

2 REPLIES 2
adina.laptuca
Contributor
  • 0
  • 3
  • 1
Registered since

Apr 12, 2018

Re: Bose QC35 II not working at all after firmware upgrade to 2.5.1

Author Accepted Answer selected by adina.laptuca

So..in the first place i upgraded to 2.5.1 then downgrading to 2.1.3 then again upgrading to 2.5.1 in the despair of fixing it somehow. All this time i used a different cable, not the one from bose box. Now, when getting home and doing more research online trying to find a solution, i found a guy saying that you should use the data cable from headphone's box. So that's what i did, downgrading again to 2.1.3 but this time using the cable from the box and this fixed my problem => now everything is working perfectly again.

 

I am never upgrading again or using a different cable.

 

 

View solution in original post

Mohsin_S
Moderator - Retired
  • 0
  • 2555
  • 115
Registered since

Dec 15, 2016

Re: Bose QC35 II not working at all after firmware upgrade to 2.5.1

@adina.laptuca Thank you for sharing this. Glad to hear that everything is working out for you now. I shall be closing this thread since this is resolved and to make it easier for our community to locate. 

 

Thank you so much again and see you around the community!

 

Mohsin - Community Support