Goose
Participant
  • 1
  • 2
  • 0
Registered since

Nov 7, 2017

Bose QC35 turn off all other sounds when I enter voice chat

So I'm trying to play Overwatch with my friends, but as soon as I join voice chat, the sound from my Overwatch game immediately dies, and if I'm already in voice and I start up Overwatch, my microphone simply does not register, no matter how much I fiddle with Discord or computer settings. The issue isn't just with Overwatch, all other noise is immediately turned off as soon as I hop into voice chat(tested with another game, youtube and a video file). I have tested this with my other computer and it does the exact same thing there, though I haven't been able to check if the issue is with just Windows 10, and I haven't tested this with a service other than Discord, because since everyone I know uses Discord it wouldn't really matter.

 

I did search the forums for issues pertaining to Discord and came upon this thread:

https://community.bose.com/t5/Wireless-Headphones/QC35-Plays-Audio-from-Mic-back-into-Headphones-ins...

and tried what was recommended, but it did not work.

I'm currently on version 1.3.4.

I did also try to have Discord on my phone and Overwatch sounds from my computer, but audio from 2 different devices is not working for me.

1 REPLY 1
Tony_G
Moderator - Retired
  • 0
  • 5470
  • 238
Registered since

Dec 15, 2016

Re: Bose QC35 turn off all other sounds when I enter voice chat

Hi Goose

 

Thanks for posting Sorry to hear about the issues you are having with Overwatch. If I could ask, does the headset seem to function normally for music and calls on your mobile device? If so the issue might be a setting in the software you are using.  After doing some research for you I was able to find this article from Blizzard with some troubleshooting.

 

Overwatch Voice Chat Not Working

 

I have also included a link to Discords support site that could help.

 

Any gamers in the community have any experience with either of these programs and want to chime in to assist?

 

 

Please let us know 

 

Tony