QC 35 ii Google assistant issues

Wistful Whisperer

QC 35 ii Google assistant issues

When I try to send a text using Google assistant. I don't see it in my text messages? Why is this? I have a Huawei p20 pro. Old phone was a Samsung galaxy and it showed them.

Also when I try to reply to a notification within the window it gives you (let's say a Facebook DM), the headphones instead disconnect and reconnect.

Also: the sound that plays when you press the Google assistant button will just come on by itself.

Yes firmware is up to date.

Any ideas? I can elaborate if needed

Frustrating as I've already had to get these replaced because I had nothing but problems with my first pair.

Re: QC 35 ii Google assistant issues

Hi, heyitsme93.


Thank you for your question. This is a strange issue, and I can understand your frustration. I expect that the Huawei P20 Pro should work well with the headphones because the QC35 IIs were given away as an incentive for pre-ordering the phone when it was released.


One bit of clarification: do the text messages send correctly but not appear in your phone, or do they not send at all?


I think that the issue that we should tackle first, to get the bottom of this, is that of the Google Assistant sound playing when you have not deliberately invoked the assistant. When this happens, can you give it a command? Does it respond, or is it just playing the sound?


I look forward to your response.


Patrick A - Community Support

Wistful Whisperer

Re: QC 35 ii Google assistant issues

The text messages seem to send correctly, yes. who im sending them to sees it, but i can't. absolutely strange.

It just seems to play the sound. I haven't tried giving it a command because usually it happens so out of the blue that I don't have enough time to even think to do that. 

It's the same sound that plays when the headphones disconnect/reconnect when I'm trying to respond to a notification. 


Re: QC 35 ii Google assistant issues

Hi again, heyitnme93.


Have you tried unpairing the headphones from within your phone's Bluetooth settings and reconnecting them, then resetting the headphones?


To unpair the headphones, navigate to Settings>Device Connections>Bluetooth and click the "information" icon that appears next to the name of your QC35s. Then click "Unpair".


Next, reset the headphones. To do this:

  1. Turn off the headset and wait 30 seconds.
  2. Plug the headset into a wall outlet using a USB charger, then wait 5 seconds.
  3. Unplug the USB cord from the headset and wait 1 minute.
  4. Turn on the headset.

If you haven't already tried these steps, please let me know if there are any changes in the behaviour of the headphones after you have.




Patrick A

Wistful Whisperer

Re: QC 35 ii Google assistant issues

Hi, I have done what you suggested and unfortunately, things are worse now. 
(Note: I knew where my bluetooth settings were but your steps to it didn't match the Huawei p20 pro. not sure if you are aware of that)


So after going through your steps, the google assistant was wiped from the headphones so I had to set it up again.

Which makes sense to me (unless this wasn't supposed to happen)

So, I tried again to use it to send a text message & it won't respond to my commands properly. It is hard to describe. The behaviour is all over the place.

EXAMPLE 1:  I'm saying "text [name] testing".... it doesn't respond... .a decent amount of seconds go by....then it disables the noise cancellation as if it's waiting for me to respond....I don't say anything....few seconds go by...... it says "when youre ready you can go ahead and start again"


If i repeat this scenario but this time respond with "testing".. seconds pass no response.. then it does the wait for response again.. I again say "testing" .....few seconds pass...then it says something like "do you want to send change or cancel."....I say send.
Person said they got the text. but I don't see it. 


It shouldn't even be asking me for that a response, as I've already told it what message to send. This worked fine on my samsung. 

i turned the headphones off and on and i got my sis to send me a facebook message. I get a notification, i tap the assistant button (expect it to read it) and it does nothing. I try again, nothing. & again and it reads me a system notification. Then the headphones turn off and back on by themselves.
I tried doing example 1: I was able to get it to work (and show the message on my end). But only twice and after multiple tries in between. tried for a 3rd time and couldn't get it to work again and the headphones turned off and back on by themselves again

Currently I can't respond to any incoming notifications. Got a text and couldn't get the assistant to read it.


Hopefully this was detailed enough lol. Please help I am honestly at my wits end here. I don't know what to do. 



Re: QC 35 ii Google assistant issues

Hi again, heyitsme93.


Thanks for going into so much detail; that's always helpful. I'm sorry for worsening the issue. At least we have change, which means we could potentially be making progress.


I wasn't aware that the menu steps that I provided didn't match the phone, so thank you for letting me know. I checked to see whether anyone in the office had a Huawei, and no one did. I'd love to be able to see if we encounter the same issue as you.


When was the last time that you rebooted the phone? It's worth trying that to see if it changes anything. Apologies for suggesting this if you've already tried it - we have to cover all bases.


I also missed a step when unpairing and re-pairing the phone. Before clicking "unpair" on your phone, try clearing the Bluetooth device list from the headphones by sliding the power button all the way and holding it for ten seconds. The headphones will play a sound that says "Device list cleared".


Please let me know if this makes any difference.


Best regards,


Patrick A

Wistful Whisperer

Re: QC 35 ii Google assistant issues

Hi, thank you for your response.

I'll give everything a go again (including the reboot & device list clearing) when I get home from work and will get back to you! I'm just on the west coast 

Wistful Whisperer

Re: QC 35 ii Google assistant issues

Hi so i tried those steps again. 
I restarted my phone as well. 


It had no problem making the bluetooth connection to the phone.


Then i launched the google assistant app & clicked the "finish headphones set up button." It said it's connected and told me to give it a try by saying "What can you do." I did, and the assistant with responded with the generic message (i dont remember the exact words) 


Then I couldn't get it to execute any command. Just absolutely zero response. Tried to say call ___. and for a few seconds, it did that disabling noise cancellation as if its waiting for some sort of reply. then the headphones turned themselves off and on again. 

i then tried pressing the assistant button again and got this weird sound that I've never head before.. Sounded like an error sound. tried a few times and kept getting the sound.


I turned the headphones off. then back on. pressed the assistant button again and this time it said "Open the google assistant app on your phone, and try that button again.." I was just looking through settings and browsing to see if I could find anything->didnt make any changes->a minute or two goes by.. I press the assistant button again and all of the sudden it's giving me the time and telling me theres no new notifications. This is the only somewhat consistent verbal communication it has been giving me the past few months. 

I tried again to say call ____ and it was just the repeated the scenario I already described...

Now here we are. This is starting to extremely concern me... is it my headphones? is it the phone?  are my headphones getting corrupted? because this is the second pair now that's giving me problems. These headphones aren't cheap so I'm sure you can imagine my frusteration..

What are the next steps? 
Thanks, look forward to your reply

P.S. As i finished typing and proofreading this, I pressed the button again and this time it read me my notifications and let me successfully reply to a WhatsApp message...?  But trying to tell it any command.. didn't work. 

I decided to test something out. So if I launch the Google Assistant app, I can command it to send a text no problem.. works just as I remember (ah good ol' days). If I do a call ___ commmand.. it doesn't work: It does the waiting-for-reply-dance again then says "when youre ready try that again".. tred it again and it executes the call command on the second attempt. 
I repeated all of this (text & call command) a second time and it did the exact same thing. Not sure what's going on here..


Re: QC 35 ii Google assistant issues



I'm sorry to hear you're still experiencing issues with your device, I understand this is an increasingly frustrating situation. I do not believe there is an issue regarding your QC35 II headphones as all your processing of your Google Assistant is done via your mobile phone. I believe the best solution for you would be to get in touch with your mobile manufacturer as your mobile is the primary port of call for processing your assistants commands. 


Many thanks,


Tegan M - Community Support 

Wistful Whisperer

Re: QC 35 ii Google assistant issues

I'm not sure how we can completely eliminate that the headphones are not the problem?

Especially since they keep turning themselves off and on when I try and give the assistant a command?