Highlighted
Participant
  • 1
  • 2
  • 1
Registered since

Jul 20, 2017

QC35 - Codec switches from AAC to SBC every power cycle (macOS Sierra)

I have an iMac running macOS Sierra, and my QC35s have the latest firmware.

 

I have my Mac set up to allow AAC streaming to the headphones. However, every time I power cycle the headphones, the codec being used by the headphones switches back to SBC. The only way to get it back to using AAC is to unpair and repair the headphones, at which point it will start using AAC again.

 

Has anyone else experiences this? Does anyone know a workaround? Is Bose not negotiating codecs correctly? Apple's AirPods, for example, don't seem to have this issue.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Participant
  • 1
  • 2
  • 1
Registered since

Jul 20, 2017

Re: QC35 - Codec switches from AAC to SBC every power cycle (macOS Sierra)

Author Accepted Answer selected by JJohnston

Well, I seem to have solved this issue on my system. It appears as though the issue my have been related to certain versions of Apple's Bluetooth Explorer (which was used to turn on AAC support in older macOS versions). Here's what I did to resolve the issue:

 

  1. Downloaded the "Additional Tools for Xcode 9" (which includes Bluetooth Explorer). Note, this downloads is part of Apple's Developer downloads. You need to sign into https://developer.apple.com
  2. Ran Bluetooth Explorer (Version 6.0.0f6)
  3. Chose Tools -> Audio Options from the Menu
  4. Clicked "Reset audio default"
  5. Closed Bluetooth Explorer
  6. Restarted my Mac

 

From that point forward, my headphones seem to default to AAC as desired.

View solution in original post

5 REPLIES 5
Highlighted
Moderator - Retired
  • 0
  • 5470
  • 237
Registered since

Dec 15, 2016

Re: QC35 - Codec switches from AAC to SBC every power cycle (macOS Sierra)

JJohnston

 

Thanks for the post. The only information I could find is that the QC35 headphones support the following Bluetooth pairing profiles:

 

Advanced Audio Distribution Profile (A2DP)
Hands Free (HFP)
Headphones (HSP)
Audio/Video Remote Control Profile (AVRCP)
BTLE (Bluetooth Low Energy)

 

I will try to investigate further and post and update you when I have more information.

 

Tony


 

 

Highlighted
Participant
  • 2
  • 1
  • 0
Registered since

Sep 11, 2017

Re: QC35 - Codec switches from AAC to SBC every power cycle (macOS Sierra)

Any progress on this? I'm coming across the same issue with my QC35 and Mac air. Sounds great when setup over AAC, but every powercycle it just changes back to the SBC codec which is getting annoying. The only fix is to repair every time.

Highlighted
Contributor
  • 7
  • 8
  • 0
Registered since

Oct 9, 2017

Re: QC35 - Codec switches from AAC to SBC every power cycle (macOS Sierra)

I am having a similar problem- only worse.

 

Every time I connect with Sierra, it connects in SCO mode in mono as a headset, with the headphone mic set as Mac input. This means instead of noise cancelling, it's piping ambient noise into my ears.

 

I have to go to Sound pref pane and change the Input from the headphones to the Mac internal mic. After a 5 sec delay, it switches to SBC, which is an improvement - but I never get AAC. I have to do this every time I use the headphones.

 

I never had this problem with Yosemite. Everything just worked automatically.

 

This needs to be a high priority fix. Or at least tell us how to change Mac settings, if that's what's needed. Thanks!

Highlighted
Participant
  • 1
  • 2
  • 1
Registered since

Jul 20, 2017

Re: QC35 - Codec switches from AAC to SBC every power cycle (macOS Sierra)

Author Accepted Answer selected by JJohnston

Well, I seem to have solved this issue on my system. It appears as though the issue my have been related to certain versions of Apple's Bluetooth Explorer (which was used to turn on AAC support in older macOS versions). Here's what I did to resolve the issue:

 

  1. Downloaded the "Additional Tools for Xcode 9" (which includes Bluetooth Explorer). Note, this downloads is part of Apple's Developer downloads. You need to sign into https://developer.apple.com
  2. Ran Bluetooth Explorer (Version 6.0.0f6)
  3. Chose Tools -> Audio Options from the Menu
  4. Clicked "Reset audio default"
  5. Closed Bluetooth Explorer
  6. Restarted my Mac

 

From that point forward, my headphones seem to default to AAC as desired.

View solution in original post

Highlighted
Community Manager - Retired
  • 0
  • 885
  • 26
Registered since

Sep 2, 2014

Re: QC35 - Codec switches from AAC to SBC every power cycle (macOS Sierra)

Thanks for sharing this workaround.  We'll close this thread as resolved.