Quiet Contributor
  • 0
  • 3
  • 0
Registered since

Dec 24, 2018

QC35 II buzzing whenever NC is on

Hi there, I’ve read some other topics reporting the same issues but I couldn’t find a solution.

A few months after purchasing the headphones, a buzz on the right cup appears every time the noise cancelling is on.

Seriously, I wasn’t expecting something like this to happen so soon in a top dollar product.

I tried with different devices and even when it is not connected to anything the buzz is still there.

Updated the firmware and nothing’s changed.

Hey, Bose! What can you do to help us?
1 REPLY 1
Highlighted
Moderator - Retired
  • 0
  • 5470
  • 235
Registered since

Dec 15, 2016

Re: QC35 II buzzing whenever NC is on

Hi lnros,

 

Thanks for reaching out to the community! I am so sorry to hear about that. We appreciate all the troubleshooting you have already tried. I would suggest attempting to reboot the headphones. 

 

To reboot the headset

  • Turn the headset off and wait for 30 seconds.
  • Plug the headset into a USB power supply via USB cord and wait 5 seconds. (Power supply needs to be plugged into the wall with power on).
  • Unplug the USB cord from the headset and wait 1 minute.
  • Turn on the headset and test if the headset works properly.

If that doesn't help, I would recommend contacting your local support team for help. Here is a link you can use. Click on your region, kindly scroll down until you see "Contact Us."

 

Regards,

 

Tony G - Community Support