nhkishan
Participant
  • 0
  • 1
  • 0
Registered since

Mar 15, 2020

QC35 II frequently voice prompts 100% battery

Qc35 II regularly prompts "Battery 100%" and disconnects from the device and after few seconds resumes connection with device but the session with my app does not resume. I use this to join conference calls and listen music. I have to go to app and resume the session.

 

This has become annoying and unusable.

1 REPLY 1
Tegan_M
Moderator

Re: QC35 II frequently voice prompts 100% battery

Hi nhkishan, 

 

I am very sorry that you are experiencing some connectivity problems with your QuietComfort 35 II headphones. I can understand why this is not ideal and is becoming increasingly frustrating, we would love to do what we can to get this resolved for you.

 

I would firstly suggest performing a reset of your headphones. Instruction on how to do this can be found below.

  • Turn off the headset and wait 30 seconds
  • Plug the headset into a wall outlet using a USB charger, then wait 5 seconds
  • Unplug the USB cord from the headset and wait 1 minute
  • Turn on the headset

Following this, check for any available firmware updates for your headphones. This can be done via a computer using a USB and visiting our firmware update website btu.bose.com, which will provide you with full instructions.

 

If this shows no sign of improvements, please let us know what device you are connecting to so we can assist you with some further troubleshooting. 

 

I look forward to hearing from you. 😊

 

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started. And don't forget to check out our new and improved Community Ranks and Rewards!