tf1846
Quiet Contributor
  • 0
  • 2
  • 0
Registered since

Jul 27, 2018

QC35 II going half-duplex on Skype Windows 10

Hello!

I am experiencing an issue with my brnad new QC35 II and I wonder whether there is someone who can help. The symptom is the following: when I am on a Skype call and the remote person is talking then he/she cannot hear me when I talk. Once he/she stops talking then I can talk and everything works fine. Essentially a half-duplex behavior.

Some additional information:

- I am using Skype on Windows 10 on an HP Spectre x360 13" i7 16GB laptop

- the QC35 II is connected to the laptop via bluetooth

- the same QC35 II connected to my phone and used on a normal phone call works in full-duplex

- a different headset connected via bluetooth to the same Skype works in full-duplex with no issues

Any ideas you can share? Thanks in advance!

 

2 REPLIES 2
Moderator

Re: QC35 II going half-duplex on Skype Windows 10

Hi tf1846,

 

Thanks for the information. Could you verify a few things?

 

  • Does the QC35 II work with full duplex when connected to your computer via a cable?
  • Would it be possible to test it using Skype on a mobile device?

Also, have you seen this page from Skype Support? 

 

Please come back and let us know.

 

Tony G - Community Support

tf1846
Quiet Contributor
  • 0
  • 2
  • 0
Registered since

Jul 27, 2018

Re: QC35 II going half-duplex on Skype Windows 10

Hi Tony.

 

I did some research. The root cause of the issue is that the Skype server puts the call in half-duplex mode, because it detects that my headset is creating echo. This is because allegedly the QC35 mic is too sensitive and when it happens it is interactively reported in the Client with the following warning message as soon as I go off-mute:

 

QC35.jpg

 

This issue has a workaround described at https://community.bose.com/t5/Headphones-Archive/QC35-sound-issues-on-Skype-for-Business-Windows-10/..., which is basically recommending to disable the QC35 mic and replace it with the laptop mic. This is not a good solution for me, because I like to walk during the calls. This is one of the advantages of having a wireless headset after all, no? 🙂

 

Has anyone solved this issue of QC35 II being detected as "poor audio quality" device by Skype in a more elegant way? Thanks!