nicolas8898
Silent Starter
  • 0
  • 1
  • 0
Registered since

Mar 9, 2019

QC35 II not charging properly (weird LED)

Hi, 

Yesterday my QC35 II ran out of battery so I plugged it to charge it, and when I unplugged it today, it said it was only at 10%. So I tried to charge it again, and I noticed the LED went instantly green, as if it were fully charged already. I had run into this issue a few months ago, and it got fixed as soon as I updated the software. So I tried doing that, and there was indeed an update that hadn't be done. But even after I got it up to date, it still wouldn't charge. Except now the LED is a bit different, it's alterning between yellow, green, and nothing at all, every 2 seconds or so. I tried to leave it plugged in despite the weird LED and use it after a while, it briefly worked and then just shut down after a few minutes. What can I do? 

1 REPLY 1
Moderator

Re: QC35 II not charging properly (weird LED)

Hi Nicolas8898, 

 

Many thanks for getting in touch and welcome to the community. I am sorry to hear you are having this issue.

 

As you have tried the update to see if this would resolve the issue, i would suggest to try and rest your headphones. To do so please follow this link - Reset.

 

If after doing this the headphones do not charge properly, I would then suggest to contact your local Customer Support Team.

 

If you select this link - Contact Us, you can select your region. Scroll to the bottom and select contact us which will provide you with their contact number.

 

Many thanks

 

Leon_C - Community Support