Highlighted
Quercus47
Silent Starter
  • 0
  • 1
  • 0
Registered since

Jan 2, 2019

QC35 II not recognized by Windows 10

I have successfully connected my Bose QC35 II to my Windows 10 computer. However, the computer does not recognize the device as anything and just shows it Device Manager as "Unspecified". So I can't use it or hear audio over it. I have searched for drivers or anything that I should install on Windows, but find nothing.

 

How do I get Windows 10 to recognize the QC35 for what it is - a pair of headphones?

 

Quercus

1 ACCEPTED SOLUTION

Accepted Solutions
TheMaker
Audible Advocate
  • 0
  • 1
  • 1
Registered since

Jan 7, 2019

Re: QC35 II not recognized by Windows 10

Bose Best Answer selected by Moderator Tony_G

Hey-o,

I solved this.

I have asus USB-BT400, win10 and wrestled with this.

 

And I did a wipe (remove devices and uninstalled my bluetooth dongle)

Switched from a USB 1-2(?) port to my PC's USB 3.0 ports

Installed everything from scratch, updated all drivers, paired and now it displays as "unspecified" BUT ALSO a headphone under "Sound"

3 REPLIES 3
Moderator

Re: QC35 II not recognized by Windows 10

Hi Quercus47,

 

Thanks for posting. I am so sorry to hear about that. When using Bluetooth audio devices with your computer there are a lot of different variables to consider. We do have another post that discusses this that might help.

 

QC35 problem with Windows 10

 

Regards,

 

Tony G - Community Support

 

TheMaker
Audible Advocate
  • 0
  • 1
  • 1
Registered since

Jan 7, 2019

Re: QC35 II not recognized by Windows 10

Bose Best Answer selected by Moderator Tony_G

Hey-o,

I solved this.

I have asus USB-BT400, win10 and wrestled with this.

 

And I did a wipe (remove devices and uninstalled my bluetooth dongle)

Switched from a USB 1-2(?) port to my PC's USB 3.0 ports

Installed everything from scratch, updated all drivers, paired and now it displays as "unspecified" BUT ALSO a headphone under "Sound"

Moderator

Re: QC35 II not recognized by Windows 10

Hi TheMaker,

 

Thanks for posting. That's a great suggestion! I am sure it's going to help a lot of users. 

 

Regards,

 

Tony G