alan617
Participant
  • 0
  • 2
  • 0
Registered since

Mar 27, 2017

QC35 Ship Mode? won't power on after 2 days of no use

i've noticed that my QC35s won't power on after 2 days or so of not using it, but as soon as i plug it in to charge and take it off the charger; it will work again.

speaking with customer service they informed me that apparently it's normal behavior and it's called ship mode where the headphones will completely power down the battery and won't power on again until it's plugged in.  just wondering if anyone else has expereinced this.  i usually just use these during the week so it's a bit tedious to have to remember to plug them in on monday am/sunday pm to make sure they are good to go for my monday am commute.

2 REPLIES 2
Tony_G
Moderator - Retired
  • 0
  • 5470
  • 238
Registered since

Dec 15, 2016

Re: QC35 Ship Mode? won't power on after 2 days of no use

alan617

 

Apologies for any confusion on this.  The QC35 products do not have a "ship mode".  The rep may have been confusing it with one of our Bluetooth speaker products. If your headsets are having intermittent power issues we would suggest contacting support and ask for an exchange. HERE is a link to your local Bose support. Click on your country, scroll down to " Contact Us"

 

Tony

alan617
Participant
  • 0
  • 2
  • 0
Registered since

Mar 27, 2017

Re: QC35 Ship Mode? won't power on after 2 days of no use

Thanks tony, i've sent support an email with a link to this thread.

hopefully i'll get someone more knowledgeable this time.