deve52
Friendly Fanatic
  • 0
  • 16
  • 1
Registered since

Dec 8, 2018

QC35 hissing in earcups?!

I have been using and thoroughly enjoying my QC35's for some time now.
Suddenly, this morning I began to hear a background hissing sound- I think it was mostly in the left earcup. There was also a noticeable degradation in the overall sound. I decided to consult the Bose Connect + app(which I hadn't used in a long time). When I opened the app, a firmware update began automatically! So, I waited for that to finish, but the hissing remained the same. I will try a reset. If that doesn't work I will contact Bose support.
In the meantime, has anyone experienced this kind of problem with their QC35's?

Regards,

Thomas.
1 ACCEPTED SOLUTION

Accepted Solutions
deve52
Friendly Fanatic
  • 0
  • 16
  • 1
Registered since

Dec 8, 2018

Re: QC35 hissing in earcups?!

Author Accepted Answer selected by deve52
Update: done a quick reset this morning..bingo! Everything is fine.
Also the firmware update from 1. to 3.0 makes a real improvement on the sound - the vocals are more prominent, the trebles are much clearer, but without any sacrifice to the bass! Being a bass player, I'm very happy with the QC35 update.
2 REPLIES 2
deve52
Friendly Fanatic
  • 0
  • 16
  • 1
Registered since

Dec 8, 2018

Re: QC35 hissing in earcups?!

Author Accepted Answer selected by deve52
Update: done a quick reset this morning..bingo! Everything is fine.
Also the firmware update from 1. to 3.0 makes a real improvement on the sound - the vocals are more prominent, the trebles are much clearer, but without any sacrifice to the bass! Being a bass player, I'm very happy with the QC35 update.
Moderator

Re: QC35 hissing in earcups?!

Hi deve52,

 

Thanks for the update! That is sure to help a lot of users.

 

Regards,

 

Tony G - Community Support