bubbles813
Wistful Whisperer
  • 0
  • 1
  • 0
Registered since

May 4, 2019

QC35II limited edition audio cable connection problem

I bought the headphone for a week,  just now I want to use the wired connect to my mobile it doesnt work, I did plug the connector to the headphone firmly but no sound,  when loosen a bit can heard awful, tinny, distance sound and sometimes sound come only from one channel.  I dont think it is the cable problem, it is the port issue.

 

We dont have refund policy here,  this is really annoying when you just bought the headphone and need to bring it to the repair center,  this is time consuming!    And i dont know why so many user reported the same problem but Bose unable to fix it.    

1 REPLY 1
Moderator

Re: QC35II limited edition audio cable connection problem

Hi Bubbles813, 

 

Thanks for reaching out and welcome to the Bose Community. 

 

I am so sorry to hear that you are having issues with your headphones, can you please let me know which limited edition color you have got so I can inform our team? 

 

To help resolve this issue I would suggest ensuring that the headphones are running on the latest software by going to btu.bose.com on a computer and following the on-screen instructions. After that, I would try cleaning the tip of the wire on both ends to ensure there is no blockage. 

 

If you are certain it is the cable port after that, please let me know which region you are in so I can direct you to the correct support channels? 

 

Many Thanks, 

Vicky W - Bose Community Support