Highlighted
willsumer
Silent Starter
  • 0
  • 1
  • 0
Registered since

Mar 7, 2019

QuietComfort 35 II No Buttons are Working

Hello,
I am having trouble with my BOSE QuietComfort 35 II Series headphones. The buttons are not working at all, in any way. They all physically press, but have no effect, including sound effects. I have updated the firmware, and tried restarting the headphones, as well as using them on a different device. None of these methods changed a thing. Any idea what could be causing it? Thank you!

1 REPLY 1
Moderator

Re: QuietComfort 35 II No Buttons are Working

Hello Willsumer, 

Thank you for reaching out to the community, sorry to hear that you are having issues with your QC 35 II headphones!
Since you have tried various troubleshooting steps already, I would recommend that you contact your local technical support team
as they can provide additional troubleshooting. 

You can reaching them by clicking Here. Then selecting your region and scrolling down the page and click on "Contact us" there you will find 
the contact details for the Tech support team. 

Hope this helps, if you have any other questions please feel free to drop a message in this thread! 

Hope you have a lovely day! 
Liam - Community Support