Notice

The Bose Community Forum was launched at a time when robust online support was not available for Bose customers. Over the past several years we have added new online service channels that provide a more interactive and complete digital experience. Additionally, we have enhanced the My Bose Account capabilities to deliver a more personalized and self-service experience. As a result, Bose has made the decision to close Community Forum for Consumer electronics products on September 30th. The Bose Pro portion of the Community will still operate as usual.


Please visit our support homepage to experience one of our many other digital service channels or simply use your Community log-in credentials to sign in to your My Bose Account to view your orders and view support options.


Thank you to all who have contributed and benefited from interacting in our Community. We look forward to continuing to serve you online.


Regards,
Bose Customer Service Team
cancel
Showing results for 
Search instead for 
Did you mean: 
greenseagar
Participant
  • 0
  • 1
  • 0
Registered since

Apr 11, 2018

Soundsport free

I am on my 3rd pair of soundsport free earbuds...i HATE THEM! They are truly a piece of crap...the left earbud disconnects ALL THE TIME! every pair is the same way. The tech said I was too far from my phone...it was in my pocket...last I knew i took my leg and pants with me wherever I went....
1 REPLY 1
Brm932
Advocate
  • 20
  • 106
  • 3
Registered since

Mar 7, 2018

Re: Soundsport free

I use mine everyday commuting in and out of the city. Train, subway, walking, biking. Every once in a while the left earbud will briefly disconnect, but instantly reconnects, and this is very rare. I love mine and they work perfectly for the most part.

Have you made sure the headphones have the updated firmware?