Highlighted
mybuddyeric
Silent Starter
  • 0
  • 1
  • 0
Registered since

Mar 2, 2019

Bose Companion 5 Control Pod not working correctly

I recently un-boxed my Companion 5 speakers after about 2 years of storage. I connected them today to my primary computer and I've noted the control pod does not respond to any touches or volume adjustments. In fact, when I tested them, the volume was on full blast and I had to adjust the volume via Windows. Now, I have read a few posts about simliar issues and have re-seated the connections and power cycled the subwoofer as well. I'm not getting any results from this advice, so I was hoping someone else knew which route I should take? Is it time to retire this system? Should I look for a replacement pod? If so, where?

Thanks!

1 REPLY 1
Moderator

Re: Bose Companion 5 Control Pod not working correctly

Hello Mybuddyeric, 

Thank you for reaching out to the community. I am sorry to hear you have an Issue with your Companion 5 Control Pod. 

What I can recommend as your best port of call would be to contact our technical support team so that they can troubleshoot with you
and if need be can provide any service options. 

To get the contact details for the technical support you can find them by clicking Here. Select your region and then scroll to the bottom of the page and click on "Contact Us" 
That will take you to the page for the details to call the team. 

If you have any other questions please do feel free to drop a message in this thread! 

I hope this will resolve your issue! 

Kind regards 
Liam - Community Support