SL2 - LED light of transmitter is off

Quiet Contributor

SL2 - LED light of transmitter is off

Hi guys,

I am having a problem with my SL2 transmitter. After connecting it, the LED light stays off - no blinking of any sort.

Just wondering whether this means that the device is broken or there is something I could still try. In case, would it be possible to buy the transmitter only?

Thanks, Antonio
6 REPLIES 6
Quiet Contributor

Re: SL2 - LED light of transmitter is off

Hi again, and sorry....

I forgot to mention that the transmitter was working fine a couple of months ago when I disconnected it due to a removal. The problem occurred when assembling the system back.

Thanks in advance, Antonio
Highlighted
Moderator

Re: SL2 - LED light of transmitter is off

Hi Antonio!

 

Thanks for reaching out to us and we appreciate the update. Sorry, you're having issues with your SL2. Just to clarify, neither of the LEDs light up when plugged in? This would indicate no power. 

 

Can you try to reseat the power cord and try different outlets? 

 

 

Let us know when you get the chance. 

 

Thanks again,

 

 

Mohsin - Community Support

Quiet Contributor

Re: SL2 - LED light of transmitter is off

Dear Mohsin,

My apologies for the late answer. I have actually tried different plugs, and reconnected all the cables several times. No luck.

Any idea of what I could try next?

Best, Antonio
Community Manager

Re: SL2 - LED light of transmitter is off

Hi Antonio,

 

Thanks for the update! 

 

Can we try and connect the headset to a computer with a USB cable and navigate to btu.bose.com?  I'd like to see if the headset gets registered by the updater and if there is an update available as well.  If this doesn't resolve the issue, I'd recommend reaching out to your local support team for service.  Just click HERE and select your country and Contact Us at the bottom of the page.

 

Warm Regards,

Tony A

Quiet Contributor

Re: SL2 - LED light of transmitter is off

Dear Tony,

My apologies for the late reply. I have just connected the transmitter to the laptop (around 20:34) with a USB cable connected to the output door of the device. The USB port does not get activated.

I have also dowloaded the Bose device updated, but I could not find an update for he SL2.

Did the headset get registered on your side?

Shall I just go to the Bose shop in Frankfurt?

Thanks, Antonio
Moderator

Re: SL2 - LED light of transmitter is off

Hi Antonio1977, 

 

Thanks for keeping us updated.

 

As your laptop could not detect the device, it would appear the system has developed a fault i.e not powering on. In this sort of situation, we would recommend getting in touch with our Customer Support Team and they will be able to assist you further with this. If you click the following link - Contact US - this will allow you to select your region, then scroll to the bottom of the web page and select "Contact Us" which will provide you with their contact number.

 

Many thanks

 

Leon_C - Community Support