cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
meso1971
Participant
  • 0
  • 5
  • 0
Registered since

May 13, 2020

Soundtouch 120 connection to Sony Bravia TV

 

From the day I first plugged in my Soundtouch 120 system I found it frustrating. 

I understand the system needs to be connected via HDMI cable to the HDMI port with "Audio Return".  In that case it is the HDMI 3 port on my TV.

 

When turning on the television, it will flash up the last source on the screen, be it a TV station, Netflix, youtube etc.

 

However, after two seconds the TV detects activity on HDMI 3 and then change the TV to display HDMI 3

 

I then turn it back to another source, it will display that source again for a further 2 or 3 seconds and then change back to HDMI 3.

 

The same happens on the third attempt.

 

Finally, on the fourth attempt, the TV stays on the source I select.

 

EVERY SINGLE TIME I use the TV I have to select what I want to watch FOUR TIMES.

 

Suggestions would be welcome and very much appreciated.

1 ACCEPTED SOLUTION

Accepted Solutions
Keith_L
Community Manager

Re: Soundtouch 120 connection to Sony Bravia TV

Author Accepted Answer selected by meso1971

Hey meso1971!

 

Welcome! Thanks for posting!

 

So the reason you will be seeing this happen, is down to an HDMI-CEC command being sent between the TV and 120 system that causes the TV to think it needs to change inputs. This is simple to fox as it will come down to one or two settings on both the TV and sound system.

 

The first thing to check is whether your TV has an Auto Input Change. Many Sony TVs do have this feature and to find it, you want to follow these steps:

  • On the TV remote control, press the HOME button.
  • Select Settings.
  • Select External Inputs or External Inpu
  • On the remote control, press the System button
  • Scroll down to 3 HDMI-CEC
  • Scroll left of right to select an HDMI-CEC setting:
    1. DEFAULT ON: Enables CEC
    2. ALTERNATIVE ON: Try this setting if you cannot control or experience unexpected control with certain devices
    3. OFF: Disables CEC
  • Press EXIT to exit the menu
  • ts in the TV Category.
  • Select BRAVIA Sync.
  • Select Auto Input Change.
  • Select ON or OFF.

IF you do not have this option, or it still happens once you have disabled this, the next setting to change is the CEC setting on the 120 system itself. To do this what you need to do is:

  • On the remote control, press the System button
  • Scroll down to 3 HDMI-CEC
  • Scroll left of right to select an HDMI-CEC setting:
    1. DEFAULT ON: Enables CEC
    2. ALTERNATIVE ON: Try this setting if you cannot control or experience unexpected control with certain devices
    3. OFF: Disables CEC
  • Press EXIT to exit the menu

Try setting this to Default On or Alternative On first and see how the system behaves then. If you still keep seeing this, then try setting it to Off.

 

Let me know how this goes!

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!

View solution in original post

2 REPLIES 2
Keith_L
Community Manager

Re: Soundtouch 120 connection to Sony Bravia TV

Author Accepted Answer selected by meso1971

Hey meso1971!

 

Welcome! Thanks for posting!

 

So the reason you will be seeing this happen, is down to an HDMI-CEC command being sent between the TV and 120 system that causes the TV to think it needs to change inputs. This is simple to fox as it will come down to one or two settings on both the TV and sound system.

 

The first thing to check is whether your TV has an Auto Input Change. Many Sony TVs do have this feature and to find it, you want to follow these steps:

  • On the TV remote control, press the HOME button.
  • Select Settings.
  • Select External Inputs or External Inpu
  • On the remote control, press the System button
  • Scroll down to 3 HDMI-CEC
  • Scroll left of right to select an HDMI-CEC setting:
    1. DEFAULT ON: Enables CEC
    2. ALTERNATIVE ON: Try this setting if you cannot control or experience unexpected control with certain devices
    3. OFF: Disables CEC
  • Press EXIT to exit the menu
  • ts in the TV Category.
  • Select BRAVIA Sync.
  • Select Auto Input Change.
  • Select ON or OFF.

IF you do not have this option, or it still happens once you have disabled this, the next setting to change is the CEC setting on the 120 system itself. To do this what you need to do is:

  • On the remote control, press the System button
  • Scroll down to 3 HDMI-CEC
  • Scroll left of right to select an HDMI-CEC setting:
    1. DEFAULT ON: Enables CEC
    2. ALTERNATIVE ON: Try this setting if you cannot control or experience unexpected control with certain devices
    3. OFF: Disables CEC
  • Press EXIT to exit the menu

Try setting this to Default On or Alternative On first and see how the system behaves then. If you still keep seeing this, then try setting it to Off.

 

Let me know how this goes!

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!

View solution in original post

meso1971
Participant
  • 0
  • 5
  • 0
Registered since

May 13, 2020

Re: Soundtouch 120 connection to Sony Bravia TV

Thanks so much.  It worked perfectly.  Now I'm kicking myself for waiting for three years to ask the question!