mom1son1dog1@comcast.net
Participant
  • 0
  • 1
  • 0
Registered since

Oct 30, 2017

Speakers making a knocking noise

I have the

. COMPANION 2 SERIES II MULTIMEDIA SPEAKERS. SERIAL 3 040274Z10590445BP

 

The main speaker is making a knocking noise constantly. IF I unplug the bottom 'skinny' wire from the back of the speaker, it stops, but have no sound at all.  I did trouble for update drivers, but it did not help.

The speaker has an ornage and a white cable plugs that are plugged into the back of the pc.  And the the 'skinny wires' that plug into the main speaker too.

 

Can anyone help me please?  I am not great with hardware problems and have no idea what to do.

I would so much appreciate your help.

 

1 REPLY 1
Michael_F
Moderator - Retired
  • 0
  • 1036
  • 81
Registered since

Sep 25, 2014

Re: Speakers making a knocking noise

Hi there!

 

The Companion 2 II has three main connections. The connection on the top which is labeled "To Left Speaker", the power connection, as well as the RCA (red and white) inputs to connect the speakers to your computer. Curiously which cable are you referring to? I have included a picture of the back of the main speaker to make it a bit easier to identify:

 

 

If the skinny wire you are referring to is on the bottom, the speaker would be upside down. Can you rotate the speaker to have the skinny connection on the top and see if the issue persists? Also, the computer should only have one cable connected from the speakers. I have also included a picture of the correct connections below:

 

 

Can you verify that the connections on your system match those seen in the image above?

 


Let us know if this helps at all and we can take it from there if needed! Thanks!

-Michael