Wave SoundTouch IV Setup Issues

Highlighted
Silent Starter

Wave SoundTouch IV Setup Issues

I had a Galaxy S6 phone and set it up to my Wave SounTouch IV system. There were no issues. Everything went smoothly. Back in August of 2018, I upgraded to a Galaxy S9 and have had problems connecting my device to my SoundTouch. I go through the setup process and do everything I am supposed to do. My SoundTouch app says there is an error and it restarts the setup process. I am wondering if this factor has anything to do with my issues: the battery of my SoundTouch remote died. I also noticed some damage to the remote, so I have been needing to replace the remote. Does the remote have anything to do with the SoundTouch app not connecting to my system? Is my current phone, the S9, compatible with this system? I have possession of my old phone, but I think it's a bit of a pain to have to use my old phone just to use my SoundTouch system. Please let me know if there is anything I can do to resolve these issues. Thank you!

1 REPLY 1
Moderator

Re: Wave SoundTouch IV Setup Issues

Hello SunnyC,

 

Thank you for your post and welcome to the community.

 

There should be no issues with being able to use the SoundTouch app on your new phone without having a working remote. However, you won't be able to use the other features of your Wave SoundTouch IV without the remote.

 

When you said that you're going through the setup process on your new phone with the SoundTouch app, are you resetting up the system to your Wi-Fi network? You should not have to do that since you already have it set up. The only thing you should need to do when you open the SoundTouch app on the new phone is to log into your existing SoundTouch account. 

 

For a new remote, go HERE, select your region, scroll to the bottom of the page, choose "Contact Us" and a phone number will be displayed for support.

 

Let us know the results.

 

Kind Regards,

Joel - Community Support