Highlighted
Pertabolis
Quiet Contributor
  • 0
  • 3
  • 0
Registered since

Jan 13, 2020

Cinemate 520 update

Hi

 

I bumped into an issue where my new TV could turn on the Cinemate on power on but will not (I never tried on the Old TV actually). After some search on in tenet it seems that an update could solve this which i can only do by USB since i do not have the Soundtouch wifi link. I never updated it actually.

 

I plugged a USB drive in the Acoustimass module, it transferred a file into it and then tried to start the update software on my computer with flash drive in. I then had an error message saying that the software could not find a file necessary to the update and that i should check my internet connection.

 

Any idea how to fix this ? I tried on a windows 7 machine, Windows 10 and a virtual machine running Mac OS X Sierra as the software is not supported by Mojave (32 bits). None of this works 😞

 

I'd really appreciate if you had an idea on how to make this work !

 

Many thanks

Pierre

 

 

PS Here's the content of the CONFIG.XML file created if this helps

 

<PRODUCTINFORMATION>
<DEVICE ID="0x0042" VARIANT="0x0000" HARDWARE="01.00.00" />
<INSTALLED>
<IMAGE SUBID="32" REVISION="01.02.00" />
<IMAGE SUBID="1" REVISION="1.0.12" />
<IMAGE SUBID="3" REVISION="1.0.12" />
<IMAGE SUBID="16" REVISION="010012" />
</INSTALLED>
<PRODUCTDATA>
<SERIALNUMBER>W4338111001347379003060</SERIALNUMBER>
<CRC8520>00000000</CRC8520>
<PAIR>20261532</PAIR>
</PRODUCTDATA>
</PRODUCTINFORMATION>

1 ACCEPTED SOLUTION

Accepted Solutions
Moderator

Re: Cinemate 520 update

Author Accepted Answer selected by Pertabolis

Hi Pierre,

 

Thank you for the update.

 

If you are not seeing that option in the CEC menu, then it would definitely suggest your system does need the firmware updated. This option was added in version 1.1.4 for the Cinemate, so if we do not see this, we are a few firmware versions behind.

 

The next thing I would recommend you do is reset the system and attempt the update again from the beginning. To do this, you would disconnect the control console and Acoustimass module from the power for 30 seconds, then reconnect the Acoustimass first, followed by the control console.

 

I would not have any way of sending the update file out to you. It is something that is dependant on the file provided by the console and not something I could provide separately.

 

Kind Regards,

 

Keith L

View solution in original post

4 REPLIES 4
Moderator

Re: Cinemate 520 update

Hi Pierre,

 

Thank you for posting and welcome to the community. I'm sorry to hear you are having trouble with the controls for and updating your Cinemate and I would be happy to help with this.

 

The TV will likely be trying to turn the Cinemate on and off with HDMI - CEC commands. Something that would be worth you trying as well as the update is adjusting the CEC settings on the Cinemate. To do this you would want to open the menu by pressing the 'System' button on the remote, then select 'HDMI - CEC'. On this page there will be 3 options, 'Default On', 'Alternative On' and 'Off'.

I would recommend trying both 'Default On' and 'Alternate On' and testing if either of those allow the control you are after.

 

For the update, have you been performing the update by following the instructions found HERE? 

 

It is worth making sure the USB drive is empty before starting the update process. Having other files on the drive can potentially cause problems with the update running. 

 

For best compatibility as well, I would recommend having the drive formatted as FAT32. You can do this on windows by connecting the drive, right-clicking on it and selecting format. Make sure you have backed up any files on the USB drive as this will erase them.

 

Let me know how you get on.

 

Kind Regards,

 

Keith L - Community Support

 

 

 

Pertabolis
Quiet Contributor
  • 0
  • 3
  • 0
Registered since

Jan 13, 2020

Re: Cinemate 520 update

Hi Keith

 

Thanks for taking the time to help. Actually other CEC functions work well, such as volume control or turning the Cinemate OFF. Only the turning ON feature doesn't work which is why i assumed that the configuration on my tv (Sony Bravia AG9) was configured correctly and a firmware update would help.

 

To answer your comments

- In the Cinemate settings i can either turn ON or OFF. No "Alternate" option. Possibly too old firmware ?

- Yes i have been performing the update described in your link using the flash drive method.

- Flash drive was freshly formatted to FAT32 and so didn't contain any other files.

 

Would you have any other leads ? For the update side, would you have the possibility to send me the files that should be copied on the drive the updater software was working ? I could then copy them and finish the procedure.

 

Many thanks again,

Pierre

Moderator

Re: Cinemate 520 update

Author Accepted Answer selected by Pertabolis

Hi Pierre,

 

Thank you for the update.

 

If you are not seeing that option in the CEC menu, then it would definitely suggest your system does need the firmware updated. This option was added in version 1.1.4 for the Cinemate, so if we do not see this, we are a few firmware versions behind.

 

The next thing I would recommend you do is reset the system and attempt the update again from the beginning. To do this, you would disconnect the control console and Acoustimass module from the power for 30 seconds, then reconnect the Acoustimass first, followed by the control console.

 

I would not have any way of sending the update file out to you. It is something that is dependant on the file provided by the console and not something I could provide separately.

 

Kind Regards,

 

Keith L

View solution in original post

Pertabolis
Quiet Contributor
  • 0
  • 3
  • 0
Registered since

Jan 13, 2020

Re: Cinemate 520 update

Hi Keith,

 

I did factory resets before but never after a 30 sec "unplug". The unplug did work. though. After restarting the system i re-inserted my flash drive which i cleaned from the previous file. The software recognized it straight away, downloaded the update in the drive, and then in the Acoustimass module. Maybe that reset would be worth adding to the update procedure webpage actually.

 

And the update fixed my CEC problem 🙂

 

So thank you very much Keith ! really appreciated 🙂

 

Best regards,

Pierre