cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Fiat25
Contributor
  • 0
  • 2
  • 1
Registered since

Jan 4, 2021

Lifestyle 20 acoustimass

I have an old Lifestyle 20 music system (bought in 1998!); it has been working wonderfully for over 20 years (well done Bose!) but now the right channel has stopped working. I have troubleshot the (cube) speakers and cables and they work (when connected to the left channel both speakers work); the Acoustimass subwoofer also works, so the music center and its connection to the Acoustimass seem to be ok (both the subwoofer and the two speakers, when connected to the left channel, work).

There seems to be a problem with the right channel exit from the Acoustimass.

 

I'm based in the UK but the system was bought in Singapore and manufactured in the USA.

Serial number [Removed by Moderator].

I have opened the acoustimass and haven't seen anything obviously wrong (I was hoping for a blown capacitor or fuse that I could have easily replaced).

 

Any suggestion on where else to look or who - in London - could repair it? It still sounds great.

Thanks

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Fiat25
Contributor
  • 0
  • 2
  • 1
Registered since

Jan 4, 2021

Re: Lifestyle 20 acoustimass

Author Accepted Answer selected by Fiat25

Hello Charlotte and thank you for your message. When I changed the audio source, as you suggested, I realised that the problem was the connection between my audio source and the Bose system (I should have thought of that!)...thank you very much for your help, problem solved! There was nothing wrong with my Lifestyle 20 to start with...so hopefully now I can enjoy this great Bose system for another 22 years (I bought it in 1998) or more!

View solution in original post

3 REPLIES 3
Charlotte_G
Moderator

Re: Lifestyle 20 acoustimass

Hey @Fiat25, welcome to the Bose Community!

 

It's really great to hear that your Lifestyle 20 system has been serving you well for so long. I'm sorry that the right channel is suddenly not working.

 

You've been through some great steps to troubleshoot already. You mentioned that you troubleshot the cables, does this include swapping the cable from the left channel to the right? This would eliminate the possibility of the issue being with the cable. 

 

Also, have you tried playing audio from different sources? 

 

I look forward to hearing back from you.

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Fiat25
Contributor
  • 0
  • 2
  • 1
Registered since

Jan 4, 2021

Re: Lifestyle 20 acoustimass

Author Accepted Answer selected by Fiat25

Hello Charlotte and thank you for your message. When I changed the audio source, as you suggested, I realised that the problem was the connection between my audio source and the Bose system (I should have thought of that!)...thank you very much for your help, problem solved! There was nothing wrong with my Lifestyle 20 to start with...so hopefully now I can enjoy this great Bose system for another 22 years (I bought it in 1998) or more!

View solution in original post

Keith_L
Community Manager

Re: Lifestyle 20 acoustimass

That's great to hear Fiat25, I'm glad your Lifestyle is working correctly again for you!

 

I'm sure you'll get another great 22 years with the system, but should you need any help with it again in the future, please don't hesitate to reach out again!

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!