Raghu.Nair
Participant
  • 0
  • 2
  • 0
Registered since

Dec 22, 2020

My Acoustimass 10 is not working

I brought the home theater in 2009 and was using it till 2017 and it worked fine but then I needed to travel so kept it without using for sometime and when I try to connect it back it is not working, I am not sure on if it is a the home theater or my Onkyo receiver or my connections are wrong.

 

Is there a way I can get my home theater checked if it is working ? Can I take this to the Bose shop and get it verified ?

 

5 REPLIES 5
Xyz987
Expert
  • 396
  • 2787
  • 120
Registered since

Oct 18, 2017

Re: My Acoustimass 10 is not working

Since the Acoustimass 10 is just a 5 speaker system with an Acoustimass module, there is not much that can go wrong.  I suspect the problem is your receiver or you don't have the speakers connected properly.  If you can figure it out, try contacting Bose support for your location.

Raghu.Nair
Participant
  • 0
  • 2
  • 0
Registered since

Dec 22, 2020

Re: My Acoustimass 10 is not working

I am in Pleasanton California, so are you telling me to go to Livermore Mall Bose center? or is there a number which I can contact for support ?

Xyz987
Expert
  • 396
  • 2787
  • 120
Registered since

Oct 18, 2017

Re: My Acoustimass 10 is not working

I'm telling you to click on the Additional Support at the top of this page and follow the links to find the support for your location.

Acarter2312
Participant
  • 0
  • 1
  • 0
Registered since

Dec 24, 2020

Re: My Acoustimass 10 is not working

Hello currently having problems with my acoustimass too. It was working fine and now it won't power on. Does yours show any indication of it having power? If so how?

Hector_B
Moderator

Re: My Acoustimass 10 is not working

Hey Acarter2312, 

 

Thanks for posting and welcome to the Community! As XYZ987 said above this system is just a 5 speaker system with an Acoustimass module, there is not much that can go wrong. Because of this, the system doesn't feature any LED status indicators. I'd recommend using a different power outlet to power the system, as well as a reset via the steps below: 

  • Power off the receiver or amplifier that connects to your speakers
  • Disconnect the power cord from the Acoustimass module or power outlet for 30 seconds

If you are still unable to power on the system, please do reach out to us via the Contact Us page on your regional Bose website here.

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!