cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Showing results for 
Search instead for 
Did you mean: 
Shaminda
Participant
  • 1
  • 6
  • 0
Registered since

Nov 30, 2019

Re: No power in bass module following update

Hi all,

looks like my bass module 700 is having the same issue. No indicator light. Tried a different power cable too. Used it around 8 months with no issue. Only thing I could notice was if I power off from the wall it was making a pop sound before turning off. (Though this doesn’t happen if I unplug few mins after standby)

 

Anyway, since couple of days, nothings working on the sub. Anyone got this fixed?

jsgordon
Contributor
  • 2
  • 4
  • 0
Registered since

Feb 23, 2019

Re: No power in bass module following update

I had to send mine back. Was within about 4 weeks of the warranty luckily.

 

Rather annoyingly when I received it back it still didn't work but did have power. It then had a light on it (which is nowhere to be explained in any manual or online).

 

When I called it in they said "oh it needs a firmware update". "Great... where do I download it?"... Oh no... I had to send it back again 🤦‍♂️🤦‍♂️. I did email them back to express how absolutely retarded this was but I got an inane response back that clearly didn't understand my point and went on a tangent. Yes the whole experience annoyed me but they are very courteous and want to help the people you speak with.

 

Many hours wasted and 2 months downtime.

 

Whilst Bose in terms of sound quality V price are probably my favourite... their systems, apps, connectivity technology is really poor. Bose have a long way to go I have many of their products but they've been left in the dust by rivals and really need to pull their socks up. Good luck! 

Shaminda
Participant
  • 1
  • 6
  • 0
Registered since

Nov 30, 2019

Re: No power in bass module following update

Thanks a lot for your quick reply.

 

I am a huge fan too and used many Bose products over the years, My Cinemate system is 12 years old and still works great. But I have to agree with you on issues these guys are having lately. 

 

I've bought the sound bar 700 and this bass module in April 2019 while traveling in Australia, (no more than 8 months). However, I am living in Sri Lanka. Can someone from Bose guide me in the right direction on what to do with a warranty claim? Considering how heavy the unit is, it would be ideal to get it fixed from a local agent.

 

Thanks again.

Shaminda
Participant
  • 1
  • 6
  • 0
Registered since

Nov 30, 2019

Re: No power in bass module following update

Just for anyone’s future reference. It was a faulty part (diode or something). Luckily I was still under warranty and the local Bose authorised service centre fixed the issue in just a day. Hope someone else will find this helpful. I’m all good for now. 🙂

Lalithk7up
Collaborator
  • 0
  • 9
  • 2
Registered since

Oct 10, 2019

Re: No power in bass module following update

Hi All,

 

I bought Lifestyle 600 from Singapore and now I'm in Sri Lanka. The system was working well so far until the software update two day back. Since yesterday, base module does not work and no power indicator is lit up.

Reading above treads, it looks like the base module is faulty. Is it affected with software update?

 

By the way, I too observe the pop sound from the base unit when I switch off the wall socket just after the system off. Is it affecting the system?

 

Thanks

Lalithk7up
Collaborator
  • 0
  • 9
  • 2
Registered since

Oct 10, 2019

Re: No power in bass module following update

Hi,

I got the problem solved from the Local Bose service agent within a day and according to them, it was a faulty part which they replaced. Now the system works well.

 

How ever, someone please advice on the Pop sound when the Base unit switch off from the wall socket.

Only Bose
Participant
  • 0
  • 1
  • 0
Registered since

Jan 28, 2021

Re: No power in bass module following update

I have the same problem, I guess Bose is not what it used to be. the gold standard of sound, now they are just like any other company out there.

Have my Bose Cass 500 for 18 months and the power goes out and now you have to pay $150.00 to fix their defective product.

 

Sad day for Bose.

Natahw
Participant
  • 0
  • 4
  • 0
Registered since

May 29, 2021

Re: No power in bass module following update

Hi there, do you name what’s the name of the faulty part that was replaced? Is it the power module circuit? I bought the Bose LifeStyle 650 from the US and shipped it all the way long. We don’t have any authorized Bose dealers nor service. What should I do in this case? The question is for anyone could help here. Thanks a bunch. 

Natahw
Participant
  • 0
  • 4
  • 0
Registered since

May 29, 2021

Re: No power in bass module following update

My bass module has no power at all. I have tried another power cable and connecting it to another socket but it did not work. Also, I tried using the 3.5 sound cable connector between the bass module and the console. It didn’t work either. I reset the console to its original factory settings. However, it still can’t see the bass module. I also have a damaged Speaker which I replaced it’s location from the right front to the left front side of the system. It did not work. When performing the speaker text, it doesn’t make any sound. How can I fix this? Can I buy another speaker separately? We don’t have an authorized Bose dealer nor service. Please advise. Thank you.

Natahw
Participant
  • 0
  • 4
  • 0
Registered since

May 29, 2021

Re: No power in bass module following update

Hi there, could you please advise on the name of the part you had ordered? And from where did you get it from? I have the same issue with my bass module. It’s very frustrating... Thanks in advance.