Highlighted
Silent Starter
  • 0
  • 1
  • 0
Registered since

Mar 26, 2020

Soundbar soundtouch 300

Hi, I have a two year old SoundTouch 300 sound bar and I went to use it yesterday and it wouldn’t turn on. I tried several things including unplugging it overnight, taking the cables out and reconnecting them, I tried a factory reset, a software update, pressing the SoundTouch button and the teletext button at the same time etc. but none of these worked. Unfortunately the bar won’t turn on or connect to WiFi or blue tooth, so I can’t connect for updates etc

5 REPLIES 5
Highlighted
Moderator

Re: Soundbar soundtouch 300

Hello mcaqg, 

 

I am sorry that your SoundTouch 300 no longer appears to be powering on. Thanks for already trying some great troubleshooting, I would like to do what I can to help. 

 

Do you get any LED indication at all on the front of the soundbar? If so, what does it state?

 

I look forward to hearing from you.

Feel more. Do more. Be more.
New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started.
Highlighted
Silent Starter
  • 0
  • 1
  • 0
Registered since

Mar 29, 2020

Re: Soundbar soundtouch 300

My SoundTouch 300 did the same thing on Friday.  It is just over 2 years old.  Will not power on & No lights displayed on front panel.  Can you order the power supply board (748871-0020) & motherboard (748866-0010) anywhere?  Or straight from Bose? Thanks

Highlighted
Quiet Contributor
  • 0
  • 2
  • 0
Registered since

Mar 29, 2020

Re: Soundbar soundtouch 300

Hi my soundbar 300 has done the same thing what is wrong?

Highlighted
Quiet Contributor
  • 0
  • 2
  • 0
Registered since

Mar 29, 2020

Re: Soundbar soundtouch 300

No lights at all ,tried disconnection ,fitted new batteries to remote ,tested remote is working , what do I do now please

Highlighted
Moderator

Re: Soundbar soundtouch 300

Hi all,

 

Sorry that you're also experiencing a power issue with your SoundTouch 300 soundbars.

 

If you have been through all of the troubleshooting mentioned in this thread, including checking the power connections, trying a different power outlet, resetting the system by removing power for 30 seconds, then please do contact our support to explore the next step. Global Contact Us > Select your country > Scroll to the bottom of the page > Click 'Contact Us'

Alternatively, if you are in the US or UK, you can use our self-service form which is found under the support section on our official website.

 

Let me know if you have any further questions.

Feel more. Do more. Be more.
New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started.