soundtouch 120 volume fail

Highlighted
Silent Starter

soundtouch 120 volume fail

I have a 3 yr old sound touch 120 home theatre that has worked flawlessly until recently. I purchased a new TV for christmas and all was well. At one point my son and I heard a loud noise come from the living room but we were unable to identify it. it was somewhere between a bang and a pop. thought nothing of it. a day or so later, my son informed me that the volume no longer goes past aproximately 15%. I currently have the system in my kitchen, and streaming VIA bluetooth, the speakers both work, but again, I cannot increase the volume. I tried to factory reset it, but the system button is non responsive on the remote(which has brand new batteries). the remote will change between all of the input settings, it will decrease the volume to zero, but stops at about 15%. I'm clueless. I fear maybe the noise could have been something letting go in possibly the woofer. And lastly it seems impossible to find anyone with a similar issue. I would love any suggestions. thanks

 

Mark

1 REPLY
Moderator

Re: soundtouch 120 volume fail

Hi Mark,

 

Thanks for posting on the Community!  Sorry to hear about the troubles, but would be happy to help!

 

  • When the issue occurred, were you able to power cycle the system by removing power for 30 seconds from the console and bass module?
  • Are you able to increase the volume beyond 15% in the SoundTouch app at all?

 

Let us know so we can further assist!

 

Warm Regards,

Tony A - Community Support