Highlighted
Participant
  • 0
  • 2
  • 0
Registered since

Jul 27, 2020

QC30 earbuds beeping and buttons don't work

My QC-30s started beeping continuously when I turn them on. Pushing the power button makes the beeping stop. It connects fine to my phone and plays music. But the buttons are no longer functioning correctly. The volume buttons do nothing. The pause/play just gives me a beep. And the power button won't shut it off. It won't turn off until it times out. I've updated to the latest firmware via the Bose app on my phone. Why is it beeping and how can I solve it?

4 REPLIES 4
Highlighted
Moderator

Re: QC30 earbuds beeping and buttons don't work

Hello tscopio, 

 

Thank you for posting and welcome to the Bose Community. Sorry to hear that you are having some beeping and button issues with your headset. 

 

Sorry to hear that the update did not resolve your issue. Let's also try and perform a reset on the headset by following these steps below: 

  • Power off your product
  • Wait 30 seconds
  • Connect your product to a wall outlet using a USB charger
  • Wait five seconds
  • Disconnect the USB cable from the headset
  • Wait one minute
  • Power on your product.

I would also like to know if these issues happen when connecting to different devices? 

 

We look forward to hearing back from you with further information. 

 

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Highlighted
Participant
  • 0
  • 2
  • 0
Registered since

Jul 27, 2020

Re: QC30 earbuds beeping and buttons don't work

Thanks. I cannot power it off - the button doesn't respond after it's been turned on. It's not a physical issue. The button works to turn it on. Then when it connects and starts beeping, the button does make the beeping stop. But it won't respond to power-off after that. So I have to wait for it to timeout (which I've set for 5min). Anyway, I plugged it in for 5sec, then unplugged for 1 min, then powered it on. It still does the beeping. It connects to multiple bluetooth sources (a Mac, a Windows Surface tablet, and my iPhone).  But same issue - beeping, clicking button stops the beeping, but then the power button doesn't work to add a new bluetooth connection nor to power off. The pause/play button will emit a beep when pressed, but doesn't pause the playback.

Highlighted
Participant
  • 0
  • 1
  • 0
Registered since

Aug 4, 2020

Re: QC30 earbuds beeping and buttons don't work

Mine are doing similar, connect to devices, buttons work to control my phone but now I have No audio, even voice prompts are gone. Product is up to date, same as app on my phone. Reset process above didn't work

Highlighted
Moderator

Re: QC30 earbuds beeping and buttons don't work

Thank you both for attempting the steps in this thread.

 

Sorry to hear that the issue still persists after this, as we have attempted all troubleshooting steps we can offer I would highly recommend getting in touch with our customer service team via clicking this link, then kindly scroll and select your region, once this is done please scroll to Contact Us. The team will be on hand and ready to help resolve this. 

 

I'd like to welcome @Ph1234567890 to the Community and hope that you are able to contribute to other threads on the Community. 

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!