Notice

The Bose Community Forum was launched at a time when robust online support was not available for Bose customers. Over the past several years we have added new online service channels that provide a more interactive and complete digital experience. Additionally, we have enhanced the My Bose Account capabilities to deliver a more personalized and self-service experience. As a result, Bose has made the decision to close Community Forum for Consumer electronics products on September 30th. The Bose Pro portion of the Community will still operate as usual.


Please visit our support homepage to experience one of our many other digital service channels or simply use your Community log-in credentials to sign in to your My Bose Account to view your orders and view support options.


Thank you to all who have contributed and benefited from interacting in our Community. We look forward to continuing to serve you online.


Regards,
Bose Customer Service Team
cancel
Showing results for 
Search instead for 
Did you mean: 
Hector_B
Moderator

Re: SoundSport Free Firmware Update 2.8.0 - December 4, 2019

Hello @Shadmonster1998

 

Thank you for posting and welcome to the Bose Community! Sorry to hear that you have experienced some audio and connection issues. I would love to help you resolve this. 

 

A great first step for us to attempt would be to perform a reset on the headset by following these steps below:

  • Place your earbuds in the charging case
  • Connect the charging case to a wall outlet using a USB charger, then wait five seconds
  • Disconnect the USB cable from the charging case, then wait one minute
  • Remove your earbuds from the case.

I would also recommend testing the headset with a few other devices as well as streaming platforms to see if the same issue occurs. 

 

We look forward to hearing back from you with the result of these steps.

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
Shadmonster1998
Participant
  • 0
  • 2
  • 0
Registered since

Mar 18, 2020

Re: SoundSport Free Firmware Update 2.8.0 - December 4, 2019

I did what you suggested and there was no change.  

Hector_B
Moderator

Re: SoundSport Free Firmware Update 2.8.0 - December 4, 2019

Thanks for posting and updating us on this @Shadmonster1998

 

As this issue still persists, I would highly recommend getting in touch with our customer service team via clicking this link, then kindly scroll and select your region, once this is done please scroll to Contact Us. The team will be on hand and ready to help.

 

Sorry that this wasn't something we could resolve for you via the community.

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!
ethiopicat
Participant
  • 0
  • 1
  • 0
Registered since

Mar 22, 2020

SoundSport Free not connecting to Bose Updater

Hi,

New on here. Have had my SSF since June last year and love them! I normally use them to connect to my iphone XS for music and it works great. However, when using them to watch movies, there is huge audio lag. I know this topic has been discussed here. My issue is, while attempting to do a firmware upgrade, my SSF will not connect to Bose Updater when connected via USB to my macbook, . I have followed the instructions as far as I can tell. What am I doing wrong?

 

P.S This would be the first firmware update am doing on my SSF.

 

Thanks in advance for you help!

 

Z

Tegan_M
Moderator

Re: SoundSport Free not connecting to Bose Updater

Hello ethiopicat, 

 

I am very sorry to hear that you are having this experience. 

 

Are you able to connect your SoundSport Free headphones to the Bose Connect app at all?

 

Have you tried using alternate internet browsers?

 

Do let us know!

Feel more. Do more. Be more.
Come check out my profile here. New to the community? Check out our Community Guidelines and How to use the Bose Community for helpful hints on getting started. And don't forget to check out our new and improved Community Ranks and Rewards!
KThomas_Perth
Participant
  • 1
  • 2
  • 0
Registered since

Apr 6, 2020

Re: SoundSport Free Firmware Update 2.8.0 - December 4, 2019

just got them home from the shop, automatically updated them to the latest firmware but left hand earbud cuts in and out when running. Definitely not a new issue. So many problems with this product in general it’s really frustrating. I will be contacting support tomorrow with a view for refund as I don’t feel replacement will fix the issue. I hear we should look at the new Bose 500’s coming out soon!

riegal
Participant
  • 0
  • 2
  • 0
Registered since

Apr 9, 2020

Re: SoundSport Free Firmware Update 2.8.0 - December 4, 2019

With the earbuds plugged into my computer & the case open the page doesn't switch to the update page. Why & how do you make it go to the update? Thank you.

KThomas_Perth
Participant
  • 1
  • 2
  • 0
Registered since

Apr 6, 2020

Re: SoundSport Free Firmware Update 2.8.0 - December 4, 2019

Ended up returning to store - picked up some 75t Elites - haven’t looked back - good luck everyone.

JGracia
Collaborator
  • 3
  • 8
  • 0
Registered since

Feb 19, 2020

Re: SoundSport Free Firmware Update 2.8.0 - December 4, 2019

Are you planning to get an update to sync audio with Apple TV, Netflix and YouTube, etc? The past firmware worked well !! this is annoying ... they have many flaws with their firmwares and worse still they are slow to help solve them. Any solution??

thbose
Participant
  • 0
  • 1
  • 0
Registered since

May 17, 2020

Re: SoundSport Free Firmware Update 2.8.0 - December 4, 2019

I think what got it working for me was to push the case button, that you normally use to see charge level, with the case open and earbuds in. But I also plugged the USB cable in and out of the computer (and a USB A -->C adapter since I was on a Macbook w/ USB-C). Eventually this combination worked for me. The update itself took between 10 and 15mins!

 

I never got it to update via the app on my Android. It kept failing about 1/2 way through even w/ the earbuds set to never go to standby etc.

 

A very frustrating upgrade experience and very poor documentation from Bose.