Highlighted
Participant
  • 0
  • 1
  • 0
Registered since

Jul 30, 2020

Soundsport Free Case

Hey guys, I have a problem with my Bose SoundSport Free Ear Phones.

 

The case is showing its fully charged, yet the case is NOT charging the earbuds at all. No matter what I do, I take them out, put them back in, clean the connections etc. The LED's flash quickly rather than slower (slower indicates charging? Faster indicates they're fully charged?) But are now completely dead and won't turn on despite the case showing all 5 white LED's.. I've updated the firmware recently and still the same problem.

 

Also, on the rare occasion they are charged, even when they're in the case (closed) they'll randomly connect to my phone when I'm not using them, this happens frequently and can become really annoying, Thus draining them while I'm not trying to use them.

 

Has anybody else experienced this? I've tried everything. The earbuds work fine once I can get them to charge. I'm convinced its the case thats the issue.

 

Thanks,

 

 

1 REPLY 1
Highlighted
Moderator

Re: Soundsport Free Case

Hey @MikeyM1991,

 

I can imagine that's quite frustrating - but I'd be happy to advise.

 

I would've advised updating the firmware, and also perform a reset as shown HERE. If you find no improvement, you may find the charging case is the culprit and will need to be replaced. Getting in touch with local support would be the best option to find a replacement  To do this, go to https://bose.life/2WPxenI > Select your country > Scroll to the bottom of the page > Click 'Contact Us'. Let me know if you have any questions regarding this.

Feel more. Do more. Be more.
New to the community? Check out the Getting Started board.
Help others find answers to your questions by clicking on 'Accept as Solution' at the bottom of a reply.
If you see a post you like, make sure to give it a thumbs up!